summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Cepoi <alex.cepoi@gmail.com>2011-05-05 13:41:33 +0300
committerAlexandru Cepoi <alex.cepoi@gmail.com>2011-05-05 13:41:33 +0300
commita3912cfebff2dc8fafa0eb757be1468b23f93500 (patch)
treef3c71d0220bfa3a66f9e32a398314018e10f2b12 /app-admin
parentremove packages already in portage (diff)
downloadalexcepoi-a3912cfebff2dc8fafa0eb757be1468b23f93500.tar.gz
alexcepoi-a3912cfebff2dc8fafa0eb757be1468b23f93500.tar.bz2
alexcepoi-a3912cfebff2dc8fafa0eb757be1468b23f93500.zip
miro and shellinabox
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/shellinabox/Manifest4
-rw-r--r--app-admin/shellinabox/files/shellinabox-conf13
-rw-r--r--app-admin/shellinabox/files/shellinabox-init32
-rw-r--r--app-admin/shellinabox/shellinabox-2.10.ebuild45
4 files changed, 94 insertions, 0 deletions
diff --git a/app-admin/shellinabox/Manifest b/app-admin/shellinabox/Manifest
new file mode 100644
index 0000000..7acdcca
--- /dev/null
+++ b/app-admin/shellinabox/Manifest
@@ -0,0 +1,4 @@
+AUX shellinabox-conf 279 RMD160 056c6784722a6ee89901645dca71f0284547345c SHA1 4542eee9a83cbb2d3ec5b39f21a6a0b4946d3ef9 SHA256 e9b6c6b2900912a328994bb17f47bf7eaadac889954bf7c7260b0d5a7e6e6f98
+AUX shellinabox-init 1080 RMD160 7c40ebc76562541141bae13eddf4339fd09519c0 SHA1 c75588e2395a30d1dcf9062d9b4fb39521f0e499 SHA256 1744acb872cd04dc2b7ed102062a121567b8e90970b7411996a367553e07db42
+DIST shellinabox-2.10.tar.gz 513430 RMD160 357ff25b15168ad3e5783d911db25b2f8d4ff71d SHA1 3bb00e75ea51aff18d9a5db13a53fa6d5e300989 SHA256 9a2dfa14fcb050de6f450b3b53522f2106cdef4a5591e3e41bd00de1e11d43cb
+EBUILD shellinabox-2.10.ebuild 810 RMD160 07ef9fdce99fb12a723fd0b7d78a2186d13a8143 SHA1 967ee2ae2ebc10a1c5eccf1bde2567629154e67d SHA256 7547c792e613b4b6df9720b21a3cad0e59b16a1cd1c493aadf8b52468b5366bd
diff --git a/app-admin/shellinabox/files/shellinabox-conf b/app-admin/shellinabox/files/shellinabox-conf
new file mode 100644
index 0000000..bb96d95
--- /dev/null
+++ b/app-admin/shellinabox/files/shellinabox-conf
@@ -0,0 +1,13 @@
+# /etc/conf.d/shellinabox
+
+# Which port we should listen on
+SHELLINABOXD_PORT="4200"
+
+# Additional parameters for shellinabox daemon
+SHELLINABOXD_OPTS=""
+
+# Example additional configuration
+# SHELLINABOXD_OPTS="--no-beep --disable-ssl --localhost-only"
+
+# vim: ft=gentoo-conf-d
+
diff --git a/app-admin/shellinabox/files/shellinabox-init b/app-admin/shellinabox/files/shellinabox-init
new file mode 100644
index 0000000..ac27e44
--- /dev/null
+++ b/app-admin/shellinabox/files/shellinabox-init
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/files/sshd.rc6,v 1.27 2009/08/12 08:09:52 idl0r Exp $
+
+depend() {
+ use logger dns
+ need net
+}
+
+SHELLINABOXD_PIDFILE=${SHELLINABOXD_PIDFILE:-/var/run/${SVCNAME}.pid}
+SHELLINABOXD_BINARY=${SHELLINABOXD_BINARY:-/usr/bin/shellinaboxd}
+SHELLINABOXD_DATADIR="${SHELLINABOXD_DATADIR:-/var/lib/shellinabox}"
+SHELLINABOXD_PORT="${SHELLINABOXD_PORT:-4200}"
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --oknodo --exec "${SHELLINABOXD_BINARY}" \
+ --pidfile "${SHELLINABOXD_PIDFILE}" \
+ -- -q --background="${SHELLINABOXD_PIDFILE}" --disable-ssl-menu \
+ --user=shellinabox --group=shellinabox \
+ --cert="${SHELLINABOXD_DATADIR}" --port="${SHELLINABOXD_PORT}" \
+ ${SHELLINABOXD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec "${SHELLINABOXD_BINARY}" \
+ --pidfile "${SHELLINABOXD_PIDFILE}" --quiet
+ eend $?
+}
diff --git a/app-admin/shellinabox/shellinabox-2.10.ebuild b/app-admin/shellinabox/shellinabox-2.10.ebuild
new file mode 100644
index 0000000..850189d
--- /dev/null
+++ b/app-admin/shellinabox/shellinabox-2.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Web based AJAX terminal emulator"
+HOMEPAGE="http://code.google.com/p/shellinabox"
+SRC_URI="http://shellinabox.googlecode.com/files/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2.0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="+ssl"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.8 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup()
+{
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 "${PN}"
+}
+
+src_configure()
+{
+ econf \
+ $(use_enable ssl) \
+ || die "econf failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ dodir "/var/lib/${PN}"
+ fowners ${PN}:${PN} "/var/lib/${PN}"
+
+ newinitd "${FILESDIR}"/${PN}-init ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf ${PN}
+}
+