summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/corewars/corewars-0.9.13-r1.ebuild')
-rw-r--r--games-simulation/corewars/corewars-0.9.13-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-simulation/corewars/corewars-0.9.13-r1.ebuild b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
index 552d250..a369dfd 100644
--- a/games-simulation/corewars/corewars-0.9.13-r1.ebuild
+++ b/games-simulation/corewars/corewars-0.9.13-r1.ebuild
@@ -22,16 +22,20 @@ DEPEND="${RDEPEND}"
src_prepare() {
epatch "${DISTDIR}"/${PN}-gtk2.patch.gz
epatch "${FILESDIR}"/${PV}-corewars-lm.patch
+ epatch "${FILESDIR}"/${PV}-fix-get_current_dir_name-prototype.patch
eautoreconf
}
+
src_configure() {
- econf $(use_enable debug gcc-debug)
+ egamesconf $(use_enable debug gcc-debug)
}
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins "${FILESDIR}/reroute.cw"
dodoc ChangeLog README doc/{TODO,DIFFERENCES,INTERESTING-COMBINATIONS}
prepgamesdirs
}