summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorandy <andy@ndyk.de>2017-02-08 16:27:21 +0100
committerandy <andy@ndyk.de>2017-02-08 16:27:21 +0100
commite4ecf1901b7fc0c864dd68ccbce6a07cfe5f82fd (patch)
tree8778176f39b13252e92906d261a6476f158da4c9 /app-admin/gopass/gopass-9999.ebuild
parentgopass: added bash/zsh completion, git snapshot and test useflags (diff)
downloadandy-e4ecf1901b7fc0c864dd68ccbce6a07cfe5f82fd.tar.gz
andy-e4ecf1901b7fc0c864dd68ccbce6a07cfe5f82fd.tar.bz2
andy-e4ecf1901b7fc0c864dd68ccbce6a07cfe5f82fd.zip
gopass: 1.0.0-r1 added symlink to pass
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin/gopass/gopass-9999.ebuild')
-rw-r--r--app-admin/gopass/gopass-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-admin/gopass/gopass-9999.ebuild b/app-admin/gopass/gopass-9999.ebuild
index 014f262..47b0643 100644
--- a/app-admin/gopass/gopass-9999.ebuild
+++ b/app-admin/gopass/gopass-9999.ebuild
@@ -21,13 +21,14 @@ DESCRIPTION="The team password manager. Written in Go."
HOMEPAGE="https://www.justwatch.com/gopass"
LICENSE="MIT"
SLOT="0"
-IUSE="X zsh-completion test"
+IUSE="X zsh-completion test symlink"
DEPEND=">=dev-lang/go-1.6:="
RDEPEND="
app-crypt/gnupg
X? ( x11-misc/xclip )
zsh-completion? ( app-shells/gentoo-zsh-completions )
dev-vcs/git
+ symlink? ( !app-admin/pass )
"
src_compile() {
@@ -46,5 +47,9 @@ src_install() {
emake bash.completion || die
newbashcomp bash.completion ${PN}
einstalldocs
+
+ if use symlink ; then
+ dosym gopass /usr/bin/pass
+ fi
}