summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Nagy <danielnagy@gmx.de>2011-06-14 02:15:25 +0200
committerDaniel Nagy <danielnagy@gmx.de>2011-06-14 02:15:25 +0200
commit7ad55cb64a7f92f0186733cf99702e7a995b5a53 (patch)
tree2a05ce37b436632e494671a41c52b056b3c13c12 /js-libs/jquerytools
parentadding jquery and new category (diff)
downloaddrevilt-7ad55cb64a7f92f0186733cf99702e7a995b5a53.tar.gz
drevilt-7ad55cb64a7f92f0186733cf99702e7a995b5a53.tar.bz2
drevilt-7ad55cb64a7f92f0186733cf99702e7a995b5a53.zip
QA, adding metadata and jquery tools and flot
Diffstat (limited to 'js-libs/jquerytools')
-rw-r--r--js-libs/jquerytools/jquerytools-1.2.5.ebuild45
-rw-r--r--js-libs/jquerytools/metadata.xml12
2 files changed, 57 insertions, 0 deletions
diff --git a/js-libs/jquerytools/jquerytools-1.2.5.ebuild b/js-libs/jquerytools/jquerytools-1.2.5.ebuild
new file mode 100644
index 0000000..5af04a6
--- /dev/null
+++ b/js-libs/jquerytools/jquerytools-1.2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit webapp versionator eutils
+
+DESCRIPTION="The missing UI library for the Web"
+HOMEPAGE="http://flowplayer.org/tools/"
+SRC_URI="http://cdn.jquerytools.org/${PV}/all/jquery.tools.min.js"
+
+SLOT="0"
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples minimal"
+
+DEPEND="js-libs/jquery"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/jquery.flot.js" "${S}/"
+ cp "${DISTDIR}/jquery.flot.*.js" "${S}/"
+ if [ use examples ] ; then
+ cp "${DISTDIR}/examples/*" "${S}/examples/"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+ webapp_src_install
+ insinto "${MY_HTDOCSDIR}"
+ doins "${P}.js" "${P}.min.js"
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}
diff --git a/js-libs/jquerytools/metadata.xml b/js-libs/jquerytools/metadata.xml
new file mode 100644
index 0000000..5954ca0
--- /dev/null
+++ b/js-libs/jquerytools/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>danielnagy@gmx.de</email>
+ <name>Daniel Nagy</name>
+</maintainer>
+<longdescription>jQuery Tools is a collection of the most important
+ user-interface components for modern websites. Used by large sites all
+ over the world.</longdescription>
+</pkgmetadata>