summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/curlpp/Manifest2
-rw-r--r--net-libs/curlpp/curlpp-0.7.3.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/curlpp/Manifest b/net-libs/curlpp/Manifest
new file mode 100644
index 0000000..8c03506
--- /dev/null
+++ b/net-libs/curlpp/Manifest
@@ -0,0 +1,2 @@
+DIST curlpp-0.7.3.tar.gz 493966 RMD160 f633346e3552106fac2a6add818ba49dc5f55039 SHA1 f3c09b29917a055523a84a6fe2c30f7eb04da6b0 SHA256 e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a653bd5
+EBUILD curlpp-0.7.3.ebuild 564 RMD160 e15fa77ecd057e308c0bc609b8934445f9ac5ce2 SHA1 3ff6dd49efaef0152854f3db3af280d7e9a086e9 SHA256 7de798c725b6b6027651bf051f744eb27a64f110a542b1546df7beafd36679b6
diff --git a/net-libs/curlpp/curlpp-0.7.3.ebuild b/net-libs/curlpp/curlpp-0.7.3.ebuild
new file mode 100644
index 0000000..9b72ebc
--- /dev/null
+++ b/net-libs/curlpp/curlpp-0.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="C++ bindings of libcurl"
+HOMEPAGE="http://curlpp.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-misc/curl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc CHANGES AUTHORS TODO doc/guide.pdf
+ insinto "/usr/share/${P}"
+ doins examples/*
+} \ No newline at end of file