aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-06-30 00:52:33 -0700
committerGregory M. Tuner <gmt@be-evil.net>2014-06-30 00:52:33 -0700
commit164ca196465f6d428e1194321f6306fbdfcba189 (patch)
tree9e21199ecad16e76c6a2aade00033db0cb9a48c0 /dev-python/pygit2/pygit2-0.21.0.ebuild
parent=media-plugins/gst-plugins-libav-1.2.4-r1: useflagwalled libav10+ support (diff)
downloadgmt-164ca196465f6d428e1194321f6306fbdfcba189.tar.gz
gmt-164ca196465f6d428e1194321f6306fbdfcba189.tar.bz2
gmt-164ca196465f6d428e1194321f6306fbdfcba189.zip
dev-python/pygit2: verbump
Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'dev-python/pygit2/pygit2-0.21.0.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-0.21.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-0.21.0.ebuild b/dev-python/pygit2/pygit2-0.21.0.ebuild
new file mode 100644
index 0000000..9a1ef5a
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.21.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="=dev-libs/libgit2-$(get_version_component_range 1-2)*"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}