aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygit2/pygit2-0.21.0.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-0.21.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-0.21.0.ebuild b/dev-python/pygit2/pygit2-0.21.0.ebuild
new file mode 100644
index 0000000..9a1ef5a
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.21.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="=dev-libs/libgit2-$(get_version_component_range 1-2)*"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}