aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-16 01:08:13 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-16 01:08:13 +0800
commit9fc377c00eb6a0627b457c4db1147494650d3bee (patch)
tree01ff06ab4029c90dbab80df6a0514f97fe37c52c /dev-python
parentdev-python/[django-appconf,django-debug-toolbar,testfixtures] updates (diff)
downloadimprovise-9fc377c00eb6a0627b457c4db1147494650d3bee.tar.gz
improvise-9fc377c00eb6a0627b457c4db1147494650d3bee.tar.bz2
improvise-9fc377c00eb6a0627b457c4db1147494650d3bee.zip
[dev-python/[django-[auth-ldap,evolution,pipeline],testfixtures] final refinements
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild6
-rw-r--r--dev-python/django-evolution/django-evolution-0.6.7.ebuild2
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.5.ebuild6
-rw-r--r--dev-python/testfixtures/testfixtures-2.3.4.ebuild14
4 files changed, 6 insertions, 22 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
index 8d8e303..1071955 100644
--- a/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
@@ -37,11 +37,7 @@ src_test() {
# Test && demo that the tests are run;
# Python.[56] trigger a harmless depracation warning
testing() {
- local exit_status=0
- PYTHONPATH=build-${PYTHON_ABI}/lib
- "$(PYTHON)" -m django_auth_ldap.tests || exit_status=1
- einfo "All tests completed OK for python"$(python_get_version)
- return ${exit_status}
+ "$(PYTHON)" -m django_auth_ldap.tests
}
python_execute_function testing
}
diff --git a/dev-python/django-evolution/django-evolution-0.6.7.ebuild b/dev-python/django-evolution/django-evolution-0.6.7.ebuild
index 5665328..a1dbc4b 100644
--- a/dev-python/django-evolution/django-evolution-0.6.7.ebuild
+++ b/dev-python/django-evolution/django-evolution-0.6.7.ebuild
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}
src_test() {
testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib/)" "$(PYTHON)" tests/runtests.py
+ PYTHONPATH="build-${PYTHON_ABI}/lib/)" "$(PYTHON)" tests/runtests.py
}
python_execute_function testing
}
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild
index cad93bb..a11812a 100644
--- a/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild
@@ -10,10 +10,10 @@ RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="http://pypi.python.org/pypi/django-debug-toolbar/"
+HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64"
-IUSE="test doc"
+IUSE="doc"
LICENSE="MIT"
SLOT="0"
@@ -41,7 +41,7 @@ src_test() {
PYTHONPATH=../../
for test in [a-z]*.py
do
- if ! "$(PYTHON)" ${test}; then
+ if ! "$(PYTHON)" ${test}; then
eerror "test "${test}" failed"
exit_status="1"
else
diff --git a/dev-python/testfixtures/testfixtures-2.3.4.ebuild b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
index 50f4443..1b479a7 100644
--- a/dev-python/testfixtures/testfixtures-2.3.4.ebuild
+++ b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
@@ -6,7 +6,7 @@ EAPI=4
PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="2.5 3.*"
-DISTUTILS_SRC_TEST="py.test" # hot off the press
+DISTUTILS_SRC_TEST="py.test"
inherit distutils eutils
DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
@@ -38,19 +38,7 @@ src_compile() {
fi
}
-# Tried using -m testfixtures/tests/ but the imports fluctuate dir levels. Need to use the patch
src_test() {
-# testing() {
-# PYTHONPATH="${S}/build-${PYTHON_ABI}/lib/"
-# pushd testfixtures/tests/ > /dev/null
-# for test in test_*.py; do
-# py.test ${test}
-# "$(PYTHON)" ${test} || die "${test} failed"
-# done
-# popd > /dev/null
-# }
-# python_execute_function testing. perfect
- py.test needs to be pointed to the tests folder
distutils_src_test ${PN}/tests/
}