summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@gmail.com>2009-04-11 23:33:12 +0200
committerHenry Gebhardt <hsggebhardt@gmail.com>2009-04-11 23:33:12 +0200
commit76b40eaf233333aa68ab72358c3baaf8668be893 (patch)
tree5f5b9b6fb80142e0881a56e315748fca7d76e20f /sci-astronomy/ftools/files
parentsci-astronomy/ftools-6.6.1: First installing ebuild. (diff)
downloadkork-76b40eaf233333aa68ab72358c3baaf8668be893.tar.gz
kork-76b40eaf233333aa68ab72358c3baaf8668be893.tar.bz2
kork-76b40eaf233333aa68ab72358c3baaf8668be893.zip
sci-astronomy/ftools-6.6.1-r1: Revision bump.
This still includes a bunch of of left-overs that might become useful. It is missing a usage message, and can't be uninstalled automatically.
Diffstat (limited to 'sci-astronomy/ftools/files')
-rw-r--r--sci-astronomy/ftools/files/hd-std-install-tasks.patch17
-rw-r--r--sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch22
-rw-r--r--sci-astronomy/ftools/files/installManPage-S-namecollision.patch30
-rw-r--r--sci-astronomy/ftools/files/lhea-fixperl-destdir.patch6
-rw-r--r--sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch15
5 files changed, 87 insertions, 3 deletions
diff --git a/sci-astronomy/ftools/files/hd-std-install-tasks.patch b/sci-astronomy/ftools/files/hd-std-install-tasks.patch
new file mode 100644
index 0000000..35ee894
--- /dev/null
+++ b/sci-astronomy/ftools/files/hd-std-install-tasks.patch
@@ -0,0 +1,17 @@
+diff --git a/heacore/BUILD_DIR/Makefile-std b/heacore/BUILD_DIR/Makefile-std
+index 13a8d97..4e68256 100644
+--- a/heacore/BUILD_DIR/Makefile-std
++++ b/heacore/BUILD_DIR/Makefile-std
+@@ -479,10 +479,10 @@ ${HD_TARG_PFX}install-tasks:
+ @for file in ${HD_INSTALL_TASKS} ${HD_INSTALL_ONLY_TASKS} .; do \
+ if [ $$file = . ]; then continue; fi; \
+ filepart=`echo $$file | sed 's%.*/%%'`; \
+- ${HD_INSTALL} $$file${BSUF} ${HD_BIN}/$$filepart${BSUF} ${HD_CP_P}; \
++ ${HD_INSTALL} $$file${BSUF} ${DESTDIR}/${HD_BIN}/$$filepart${BSUF} ${HD_CP_P}; \
+ status=$$?; if [ $$status -ne 0 ]; then exit $$status; fi; \
+ if [ "x${HD_BIN}" != "x${HD_TOP_BIN}" ]; then \
+- ${HD_INSTALL} ${HD_BIN}/$$filepart${BSUF} ${HD_TOP_BIN}/$$filepart${BSUF} ${HD_LN_S}; \
++ ${HD_INSTALL} ${HD_BIN}/$$filepart${BSUF} ${DESTDIR}/${HD_TOP_BIN}/$$filepart${BSUF} ${HD_LN_S}; \
+ status=$$?; if [ $$status -ne 0 ]; then exit $$status; fi; \
+ fi; \
+ done
diff --git a/sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch b/sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch
new file mode 100644
index 0000000..fb6f3c9
--- /dev/null
+++ b/sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch
@@ -0,0 +1,22 @@
+diff --git a/tcltk/BUILD_DIR/Makefile.in b/tcltk/BUILD_DIR/Makefile.in
+index a4f2be7..210bc10 100644
+--- a/tcltk/BUILD_DIR/Makefile.in
++++ b/tcltk/BUILD_DIR/Makefile.in
+@@ -158,7 +158,7 @@ install-iwidgets:
+ ${MAKE} subdir-iwidgets HD_TARGET="install" \
+ prefix=${HD_EXEC_PFX} exec_prefix=${HD_EXEC_PFX} \
+ LD_LIBRARY_PATH="${TCL_DIR}:${LD_LIBRARY_PATH}"
+- @cd ${HD_TOP_LIB}; rm -f iwidgets; ln -sf ${IWIDGETS} iwidgets
++ @cd "${DESTDIR}"/${HD_TOP_LIB}; rm -f iwidgets; ln -sf ${IWIDGETS} iwidgets
+ #-------------------------------------------------------------------------------
+
+ # Specializations for iwidgets2.2.0
+@@ -223,7 +223,7 @@ publish-tclreadline:
+ install-tclreadline:
+ ${MAKE} subdir-tclreadline HD_TARGET="install" \
+ prefix=${HD_EXEC_PFX} exec_prefix=${HD_EXEC_PFX} TCLRL_DIR=${HD_LIB}/tclreadline${TCLREADLINE_VERS} TCLRL_LIBDIR=${HD_LIB} tclrldir=${HD_LIB}/tclreadline${TCLREADLINE_VERS}
+- @cd ${HD_TOP_LIB}; rm -f tclreadline; ln -sf tclreadline${TCLREADLINE_VERS} tclreadline
++ @cd "${DESTDIR}"/${HD_TOP_LIB}; rm -f tclreadline; ln -sf tclreadline${TCLREADLINE_VERS} tclreadline
+ @if [ "x${HD_LIB_STYLE}" = xstatic ]; then \
+ ${HD_INSTALL} ${HD_LIB}/libtclreadline.a ${HD_LIB}/lib${TCLREADLINE}.a ${HD_LN_S}; \
+ fi
diff --git a/sci-astronomy/ftools/files/installManPage-S-namecollision.patch b/sci-astronomy/ftools/files/installManPage-S-namecollision.patch
new file mode 100644
index 0000000..fe9cd1c
--- /dev/null
+++ b/sci-astronomy/ftools/files/installManPage-S-namecollision.patch
@@ -0,0 +1,30 @@
+diff --git a/tcltk/tcl/unix/installManPage b/tcltk/tcl/unix/installManPage
+index 93fd925..765d838 100755
+--- a/tcltk/tcl/unix/installManPage
++++ b/tcltk/tcl/unix/installManPage
+@@ -3,7 +3,7 @@
+ ZIP=:
+ while true; do
+ case $1 in
+- -s | --symlinks ) S="-s ";;
++ -s | --symlinks ) SYM="-s ";;
+ -z | --compress ) ZIP=$2; shift ;;
+ -e | --extension ) Z=$2; shift ;;
+ -s | --suffix ) SUFFIX=$2; shift ;;
+@@ -18,7 +18,7 @@ fi
+
+ MANPAGE=$1
+ DIR=$2
+-test -z "$S" && S="$DIR/"
++test -z "$SYM" && SYM="$DIR/"
+
+ # A sed script to parse the alternative names out of a man page.
+ #
+@@ -62,6 +62,6 @@ for f in $NAMES; do
+ $ZIP $DIR/$FIRST
+ else
+ rm -f $DIR/$f $DIR/$f.*
+- ln $S$FIRST$Z $DIR/$f$Z
++ ln $SYM$FIRST$Z $DIR/$f$Z
+ fi
+ done
diff --git a/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch b/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
index 625f12a..527bca9 100644
--- a/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
+++ b/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
@@ -1,7 +1,7 @@
-diff --git a/heacore/BUILD_DIR/lhea-fixperl b/heacore/BUILD_DIR/lhea-fixperl
+diff --git a/lhea-fixperl b/lhea-fixperl
index 927387b..e052b59 100755
---- a/heacore/BUILD_DIR/lhea-fixperl
-+++ b/heacore/BUILD_DIR/lhea-fixperl
+--- a/lhea-fixperl
++++ b/lhea-fixperl
@@ -21,6 +21,7 @@ else
fi
diff --git a/sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch b/sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch
new file mode 100644
index 0000000..1392dce
--- /dev/null
+++ b/sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch
@@ -0,0 +1,15 @@
+diff --git a/ftools/BUILD_DIR/Makefile b/ftools/BUILD_DIR/Makefile
+index 67c72c4..9940349 100644
+--- a/ftools/BUILD_DIR/Makefile
++++ b/ftools/BUILD_DIR/Makefile
+@@ -43,8 +43,8 @@ install-BUILD_DIR:
+ fixpfiles:
+ @LHEA_DATA=${HD_TOP_REFDATA}; LHEA_HELP=${HD_TOP_HELP}; \
+ export LHEA_DATA; export LHEA_HELP; \
+- if [ -d ${HD_PFILES} ]; then \
+- cd ${HD_PFILES}; lhea-fixpfiles; \
++ if [ -d "${DESTDIR}"/${HD_PFILES} ]; then \
++ cd "${DESTDIR}"/${HD_PFILES}; lhea-fixpfiles; \
+ fi
+
+ # Specializations for xspec (spectral dir) in case we only have xspec data: