summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ftools/ftools-6.6.1-r1.ebuild')
-rw-r--r--sci-astronomy/ftools/ftools-6.6.1-r1.ebuild58
1 files changed, 22 insertions, 36 deletions
diff --git a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
index 6430124..fdfff92 100644
--- a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
+++ b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
@@ -5,14 +5,6 @@
EAPI=2
inherit eutils
-# A well-used example of an eclass function that needs eutils is epatch. If
-# your source needs patches applied, it's suggested to put your patch in the
-# 'files' directory and use:
-#
-# epatch "${FILESDIR}"/patch-name-here
-#
-# eclasses tend to list descriptions of how to use their functions properly.
-# take a look at /usr/portage/eclasses/ for more examples.
DESCRIPTION="General-Use FTools for manipulating and inspecting FITS files"
HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html"
@@ -29,6 +21,18 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/heasoft-${PV}/"
PREFIX="/usr/heasoft-${PV}"
+MSG="The HEASOFT General-Use FTools have been installed into
+$PREFIX.
+Portage doesn't know about them. If you want to remove
+HEASOFT, you need to do
+'rm -rf \"${PREFIX}\"'.
+
+To use the HEASOFT, you need to set the HEADAS environment
+variable, and source the headas init script, like so
+ export HEADAS=\"${PREFIX}/<arch-dependent-dir>\"
+ . \${HEADAS}/headas-init.sh
+if you are using a bourne-shell. There is also an initscript
+for C-shells in the same directory as the one for bourne-shells."
src_prepare() {
for subdir in tcl tk; do
@@ -36,48 +40,30 @@ src_prepare() {
epatch "${FILESDIR}"/installManPage-S-namecollision.patch \
|| die "epatch failed"
done
- #cd "${S}"/heacore/BUILD_DIR
- #epatch "${FILESDIR}"/hd-std-install-tasks.patch
- # The same source file hd_install.c occurs multiple times, and needs to
- # be patched to support $DESTDIR.
- #for subdir in . demo tcltk ftools heacore heatools; do
- # cd "${S}"/${subdir}/BUILD_DIR
- # epatch "${FILESDIR}"/hd_install-destdir.patch || die "epatch failed"
- # epatch "${FILESDIR}"/lhea-fixperl-destdir.patch || die "epatch failed"
- #done
- #cd "${S}"
- #epatch "${FILESDIR}"/install-iwidgets-symlink-destdir.patch \
- # || die "epatch failed"
- #cd "${S}"/ftools/BUILD_DIR
- #epatch "${FILESDIR}"/lhea-fixpfiles-destdir.patch || die "epatch failed"
-# epatch "${FILESDIR}"/no-tk-docs.patch || die "epatch failed"
-# epatch "${FILESDIR}"/headas-init-destdir.patch || die "epatch failed"
}
src_configure() {
+ [[ -d "${PREFIX}" ]] && die "Please remove previous installation."
+ ewarn "This ebuild is no good."
cd BUILD_DIR
econf --prefix="${PREFIX}" || die "econf failed"
}
src_compile() {
cd BUILD_DIR
- emake -j1 || die "emake failed"
+ emake || die "emake failed"
+
+ echo "${MSG}" > WTF
}
src_install() {
+ # The heasoft install scripts don't allow for $DESTDIR. Thus we
+ # must let headas install itself. This is very bad, I know.
addwrite "${PREFIX}"
cd BUILD_DIR
- emake -j1 install || die "emake install failed"
-# emake -j1 DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "emake install failed"
+ emake install || die "emake install failed"
- #emake \
- # prefix="${D}"/usr \
- # mandir="${D}"/usr/share/man \
- # infodir="${D}"/usr/share/info \
- # libdir="${D}"/usr/$(get_libdir) \
- # install || die "emake install failed"
+ dodoc WTF
- # The portage shortcut to the above command is simply:
- #
- #einstall DESTDIR="${D}" INSTALL_ROOT="${D}" || die "einstall failed"
+ elog "${MSG}"
}