summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ftools/Manifest2
-rw-r--r--sci-astronomy/ftools/ftools-6.6.1-r1.ebuild58
2 files changed, 23 insertions, 37 deletions
diff --git a/sci-astronomy/ftools/Manifest b/sci-astronomy/ftools/Manifest
index bfd3077..8565d94 100644
--- a/sci-astronomy/ftools/Manifest
+++ b/sci-astronomy/ftools/Manifest
@@ -8,5 +8,5 @@ AUX lhea-fixpfiles-destdir.patch 562 RMD160 fd1af4e68bb7885652a6e81404371bba5fe8
AUX no-tk-docs.patch 738 RMD160 d69e261c402d2e545f109495be999eaeb5d37620 SHA1 35ff2466c06df162e584b76ad3ef15d05b9e2f42 SHA256 0782fe89fc4d29eb4ba2c01f8d6420762060a156db7cb7cf7847f3a5a366f44c
AUX par2-destdir.patch 580 RMD160 56efb9a0049486f7736fe6bcd08947de45599ffa SHA1 97e12b9bb9feccf1be3d3bc1b83a6e79d4078f37 SHA256 aba4b7ba28204b6863c5e8ade5528874ef0606e15d03b1ea167ab9732ac481d4
DIST heasoft6.6.1src.tar.gz 41783649 RMD160 b03d23ad61023d9f9d8df247a448c8ad4d66f98d SHA1 58376bd6ce4dbc9cdb3a901c977602d120d0609e SHA256 f73e78e5a5b6af8b9db0aee66957bf450980455fc78a8d7aa056e6013b49285d
-EBUILD ftools-6.6.1-r1.ebuild 2475 RMD160 7f6456b0b8734500a57a0d85ef15df769c9ef423 SHA1 40f23c4ab97e4c281697acff679c972170435f7c SHA256 b3d3f28155199ec30b7d5179f5c54eb7ff2378a66341080401eb4661d6ef5784
+EBUILD ftools-6.6.1-r1.ebuild 1696 RMD160 e4c857efb26e674b16bc698ee7a83cc3613c25b0 SHA1 2fbc77d0ae813406dd970094fe2df47418d97c39 SHA256 ebbdc4c2197901983d4efe4343b3a3ec7f21f3a9c66fa0dc0ba6f6b2925edc5f
EBUILD ftools-6.6.1.ebuild 1911 RMD160 ba849617b62ddbac13c1fab45157d1bbd05db7bf SHA1 078a2aa8bf1a5e5af3b2da31c835f2c630f677e9 SHA256 4e389dd716cb9e4e9243178c4c067b96f2839ced5ea5446b57c163f918069be7
diff --git a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
index 6430124..fdfff92 100644
--- a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
+++ b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
@@ -5,14 +5,6 @@
EAPI=2
inherit eutils
-# A well-used example of an eclass function that needs eutils is epatch. If
-# your source needs patches applied, it's suggested to put your patch in the
-# 'files' directory and use:
-#
-# epatch "${FILESDIR}"/patch-name-here
-#
-# eclasses tend to list descriptions of how to use their functions properly.
-# take a look at /usr/portage/eclasses/ for more examples.
DESCRIPTION="General-Use FTools for manipulating and inspecting FITS files"
HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html"
@@ -29,6 +21,18 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/heasoft-${PV}/"
PREFIX="/usr/heasoft-${PV}"
+MSG="The HEASOFT General-Use FTools have been installed into
+$PREFIX.
+Portage doesn't know about them. If you want to remove
+HEASOFT, you need to do
+'rm -rf \"${PREFIX}\"'.
+
+To use the HEASOFT, you need to set the HEADAS environment
+variable, and source the headas init script, like so
+ export HEADAS=\"${PREFIX}/<arch-dependent-dir>\"
+ . \${HEADAS}/headas-init.sh
+if you are using a bourne-shell. There is also an initscript
+for C-shells in the same directory as the one for bourne-shells."
src_prepare() {
for subdir in tcl tk; do
@@ -36,48 +40,30 @@ src_prepare() {
epatch "${FILESDIR}"/installManPage-S-namecollision.patch \
|| die "epatch failed"
done
- #cd "${S}"/heacore/BUILD_DIR
- #epatch "${FILESDIR}"/hd-std-install-tasks.patch
- # The same source file hd_install.c occurs multiple times, and needs to
- # be patched to support $DESTDIR.
- #for subdir in . demo tcltk ftools heacore heatools; do
- # cd "${S}"/${subdir}/BUILD_DIR
- # epatch "${FILESDIR}"/hd_install-destdir.patch || die "epatch failed"
- # epatch "${FILESDIR}"/lhea-fixperl-destdir.patch || die "epatch failed"
- #done
- #cd "${S}"
- #epatch "${FILESDIR}"/install-iwidgets-symlink-destdir.patch \
- # || die "epatch failed"
- #cd "${S}"/ftools/BUILD_DIR
- #epatch "${FILESDIR}"/lhea-fixpfiles-destdir.patch || die "epatch failed"
-# epatch "${FILESDIR}"/no-tk-docs.patch || die "epatch failed"
-# epatch "${FILESDIR}"/headas-init-destdir.patch || die "epatch failed"
}
src_configure() {
+ [[ -d "${PREFIX}" ]] && die "Please remove previous installation."
+ ewarn "This ebuild is no good."
cd BUILD_DIR
econf --prefix="${PREFIX}" || die "econf failed"
}
src_compile() {
cd BUILD_DIR
- emake -j1 || die "emake failed"
+ emake || die "emake failed"
+
+ echo "${MSG}" > WTF
}
src_install() {
+ # The heasoft install scripts don't allow for $DESTDIR. Thus we
+ # must let headas install itself. This is very bad, I know.
addwrite "${PREFIX}"
cd BUILD_DIR
- emake -j1 install || die "emake install failed"
-# emake -j1 DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "emake install failed"
+ emake install || die "emake install failed"
- #emake \
- # prefix="${D}"/usr \
- # mandir="${D}"/usr/share/man \
- # infodir="${D}"/usr/share/info \
- # libdir="${D}"/usr/$(get_libdir) \
- # install || die "emake install failed"
+ dodoc WTF
- # The portage shortcut to the above command is simply:
- #
- #einstall DESTDIR="${D}" INSTALL_ROOT="${D}" || die "einstall failed"
+ elog "${MSG}"
}