aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-03-20 21:24:54 +0000
committerPaul Healy <lmiphay@gmail.com>2019-03-20 21:24:54 +0000
commit3ac380aadc762acb3ba2f30118297a0f8f4a42cb (patch)
tree675e17b3f46c5c2f36b8d976dc85c3ac4b0718b8
parentbump retry on stop time to 20 seconds (diff)
downloadlmiphay-3ac380aadc762acb3ba2f30118297a0f8f4a42cb.tar.gz
lmiphay-3ac380aadc762acb3ba2f30118297a0f8f4a42cb.tar.bz2
lmiphay-3ac380aadc762acb3ba2f30118297a0f8f4a42cb.zip
revbump gitea
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.8.0_rc1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index d891218..885e54a 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -4,4 +4,6 @@ AUX gitea.initd-r1 688 BLAKE2B eb2341dee53f3fd92c49137855615d9ae7ca77efc396e2d2e
AUX gitea.logrotated 87 BLAKE2B 373830ddd6eed0ce2f0f7b1dab14e4a253e5a56a73f477cfadbc6deec373846d4df2d697735391581771699d5a6513acb0e14a446873de01eba10d19e3a6bd88 SHA512 798f3fc33026f19dd31ffa78b9b1ed313d7b82b19c047f509e896c1798b2925a1bb7c4998d98a6b47e728979bf7132fb1c2a80eb7fda096a763d6791631cb6d4
AUX gitea.service 472 BLAKE2B 4c728e2987d0c0a86e65d4b9c1a59f6193ff8a3f9b066991a06f495ad1c5586b3497c71fca1cce5b65f167af09343e7bf3215ee5e8fdefa539e384198d2d88d6 SHA512 6666fe3b4cdbb78a58db4a6bf47a15e6be9ab30b666c6eb77a9e8a002d8c0abd510fc75ef463a11ee6892ab12c98943774616072cb64fd9f2fa42ff8f676aa95
DIST gitea-1.7.4.tar.gz 20858340 BLAKE2B 81d896d313abe25bc1a5becd16249c2ce39ab45d9f40ccf3a565b6777847c7256d5b131f597be237df57513a207978e23480ad3c6087bbc588afe8bbcd46d5c9 SHA512 eede6d410529b1facf65061256e48fee7d459aa12d8c55346d3ad78004a45b7bf667536979fe92270a85901102fd9cddb8183490e16f912b742e799ca912e370
+DIST gitea-1.8.0_rc1.tar.gz 24248170 BLAKE2B bd567734f6f636fc38d89bf5095e74e8a8d77613691df03875ee18117e0f7ac1bc90a65a24d1b165c14084e482eeb71d36021248c733f2ced6e3fbd8d5bee691 SHA512 ed91b667611f6627c49d77ad6631044d135b45ec86b8a87bbe1a7b2918400672d53c8fea8509ccc85c4d23d7bbf9f11903e29f20c101fe682ec7d08691a58595
EBUILD gitea-1.7.4.ebuild 1937 BLAKE2B 62966ac3fb1df33057720084d66e5ff7ca07e72e8c14fec6ca3c3c128bd782804ddb614c605e83dd5dd4606a252d5d010997f07cc685473096d0cc086e5bbb3d SHA512 4184590b31bbe750d08ea20ef7c6099f8c61e69d41bc458f9dca0de20cbe125283cd489ddca4bf2802a2fa7caa626709eb17f02c4608a656904d082dd7e3fea5
+EBUILD gitea-1.8.0_rc1.ebuild 1993 BLAKE2B 6142780e1970faaa80cfe2735e6179f662419e78f459f2d5294a436a71b391cfd5a011ccf8b05afb1067f81e8bc50951f1646f1bca893e05668d666a1fdc3d18 SHA512 2fe611bea5df7c11292a1471a44546c518992ab883db3d6aa31e7537ab9dbfea8b343c1f28e4fbd0f3fa906d70acd399c19b1be916f5a73d219049751ff9a04b
diff --git a/www-apps/gitea/gitea-1.8.0_rc1.ebuild b/www-apps/gitea/gitea-1.8.0_rc1.ebuild
new file mode 100644
index 0000000..084d3a0
--- /dev/null
+++ b/www-apps/gitea/gitea-1.8.0_rc1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user systemd golang-build golang-vcs-snapshot versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+
+EGO_PN="code.gitea.io/gitea"
+KEYWORDS="~amd64 ~arm"
+
+DESCRIPTION="A painless self-hosted Git service, written in Go"
+HOMEPAGE="https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-go/go-bindata"
+RDEPEND="dev-vcs/git"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitea git
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
+ -e "s/-ldflags '-s/-ldflags '/" \
+ -e "s/GOFLAGS := -i -v/GOFLAGS := -v/" \
+ src/${EGO_PN}/Makefile || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
+ TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="-fno-PIC" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin gitea
+ insinto /var/lib/gitea/conf
+ newins custom/conf/app.ini.sample app.ini.example
+ popd || die
+ newinitd "${FILESDIR}"/gitea.initd-r1 gitea
+ newconfd "${FILESDIR}"/gitea.confd gitea
+ keepdir /var/log/gitea /var/lib/gitea/data
+ fowners -R git:git /var/log/gitea /var/lib/gitea/
+ systemd_dounit "${FILESDIR}/gitea.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
+ elog "No app.ini found, copying initial config over"
+ cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
+ chown git:git /var/lib/gitea/conf/app.ini
+ else
+ elog "app.ini found, please check example file for possible changes"
+ ewarn "Please note that environment variables have been changed:"
+ ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
+ ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
+ fi
+}