aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2021-06-10 09:56:46 +0100
committerPaul Healy <lmiphay@gmail.com>2021-06-10 09:56:46 +0100
commit60e09284de996b8a92e255c643e567154beecaf7 (patch)
tree70f4cfab0e5afa750b0bc957cadf4793151b3070
parentrevbump pynetgear and fix py ver (diff)
downloadlmiphay-60e09284de996b8a92e255c643e567154beecaf7.tar.gz
lmiphay-60e09284de996b8a92e255c643e567154beecaf7.tar.bz2
lmiphay-60e09284de996b8a92e255c643e567154beecaf7.zip
update py ver for ha
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--app-misc/homeassistant-bin/Manifest3
-rw-r--r--app-misc/homeassistant-bin/homeassistant-bin-0.108.9.ebuild10
-rw-r--r--app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild106
3 files changed, 6 insertions, 113 deletions
diff --git a/app-misc/homeassistant-bin/Manifest b/app-misc/homeassistant-bin/Manifest
index f697954..964f8de 100644
--- a/app-misc/homeassistant-bin/Manifest
+++ b/app-misc/homeassistant-bin/Manifest
@@ -4,5 +4,4 @@ AUX homeassistant.logrotate 280 BLAKE2B a1e5ecf35df38b4928415af19c72bb3012fa8ea8
AUX homeassistant.service 261 BLAKE2B 54819aa30aa5564aca693fa2dd70ad4a9831929a33f1042542e2555fa1ec2cb5cefd746b6abc308bc970f627803279dc3caf5fbf3de5c94b3fd73760e1343a38 SHA512 83f6ba1782f844c290f349ff50bdea8d8d88d41e2f39f3f7d5a015a0f463a4c8f7328acbd3838380cf6ca78090b39ebdbeb5e3f39607b5e307c0e53ff55ee697
AUX recorder.yaml 114 BLAKE2B af04840805aa13124208584e7f1d40335905a083ee7deead5c0e4324c969f2a231c801c23e42075782950aba7535496d92747bf03efd73a80b0d07e8492d18f6 SHA512 cb4e353e54fb6dc7034569b8d62ddcdca92680c23c2c4e1ce707d21cf95e93f41a0c44521d8c3ee90b68c830f6b8e65dab82ae64bfa09727ae384550f7de0c94
AUX update-homeassistant 1672 BLAKE2B b8a99eb0f13847e28acc5f52a2313973d791e5993f76490e534f73f188fd44895dfac5d751226bc769787d466a0d8bbdb3ec369dc8a0cedd7144fce779cd9de0 SHA512 26e0cfc66f2d48218db7fe6b3e9c0b92d765f6eb6c91bc39aedb56c6d6f419ce263c8d47637936622c8afcdf0cb7c1864e249cd190a110ea996cb4eff5122a81
-EBUILD homeassistant-bin-0.108.9.ebuild 4256 BLAKE2B d5b948fbac39f55786b8de55015545aae7eff3abc9d13a40dc4ecf600daba59c570dd1ca6d6af69b0d36859aa600b14abbaf834eddc2d05e2659b587fac145f9 SHA512 ded2a7a8f183674643832004a2779281dc67b494372ad76dea72b7097623e0890fcb34b84f9a384bfdd4c210e3d3803f8046e91ad8a09455e5603b585398e632
-EBUILD homeassistant-bin-9999.ebuild 2570 BLAKE2B a585a757290d38e61908524df8282b8d48916b7c23cb2b51e625d6d08ca409b6ef357f5bc06f1d1022bbfc4120112e292dac343f20692b11db8e1e66e15cf104 SHA512 c22d886de264eac1cc4bb3f7ecd7824ca4edac987f80ce29661c865557413f08399f2cd26683bf91fbeec99be0d92e390b04a246d0219de2398d19dedee1637d
+EBUILD homeassistant-bin-0.108.9.ebuild 4240 BLAKE2B 9c79462d07dbf4961ecb920dc4cc5467839050c19c7e151b0c067fbabec3c35ca00311c22a2844f26f762a0dc8dccb31c410e013f6066efe32f080ad72f882d8 SHA512 b7696e821f6a27e3ceba5b4c2e79840a088d0a4d64b92e74220d9d4edb16d3366e470ef764fb7e26a0f99c9f4ab16f9c063c4f39e9f8ca70ccc4b798eff91aa7
diff --git a/app-misc/homeassistant-bin/homeassistant-bin-0.108.9.ebuild b/app-misc/homeassistant-bin/homeassistant-bin-0.108.9.ebuild
index e6ad1c2..2e2f626 100644
--- a/app-misc/homeassistant-bin/homeassistant-bin-0.108.9.ebuild
+++ b/app-misc/homeassistant-bin/homeassistant-bin-0.108.9.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{8,9} )
inherit user readme.gentoo-r1 eutils distutils-r1 systemd
MY_PN="${PN/-bin/}"
-DESCRIPTION="Home automation platform (Python 3 required)"
+DESCRIPTION="Home automation platform"
HOMEPAGE="https://home-assistant.io"
SRC_URI="" # pip installs HA version $PV from PyPI
@@ -18,7 +18,7 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="maint mysql"
-PY_HA="3.7"
+PY_HA="3.8"
DEPEND="
${PYTHON_DEPS}
@@ -127,7 +127,7 @@ src_install() {
}
pkg_postinst() {
- elog "homeassistant requires python 3.5 (or later)"
+ elog "homeassistant requires python 3.8 (or later)"
elog ""
elog "This ebuild installs homeassistant into a virtualenv built for:"
elog ""
diff --git a/app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild b/app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild
deleted file mode 100644
index 261a0db..0000000
--- a/app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2020 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit user readme.gentoo-r1 eutils distutils-r1 systemd
-
-MY_PN="${PN/-bin/}"
-
-DESCRIPTION="Home automation platform (Python 3 required)"
-HOMEPAGE="https://home-assistant.io"
-SRC_URI="" # pip installs latest HA from PyPI
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="maint"
-
-DEPEND="
- ${PYTHON_DEPS}
- !app-misc/homeassistant
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${DEPEND}
- app-admin/logrotate
- maint? (
- app-crypt/certbot
- app-crypt/ssl-cert-check
- net-misc/dropbox-uploader
- virtual/logger
- )
-"
-
-INSTALL_DIR="/opt/${MY_PN}"
-
-DISABLE_AUTOFORMATTING=1
-DOC_CONTENTS="
- The HA interface listens on port 8123 - this _will_ take a minute or two to appear
-
- hass configuration is in: /etc/${MY_PN}
- daemon command line arguments are configured in: /etc/conf.d/${MY_PN}
-
- logging is to: /var/log/${MY_PN}/{server,errors,stdout}.log
-
- The sqlite db is by default in: /etc/${MY_PN}
- To move it after ${MY_PN} has run once and while ${MY_PN} is stopped:
- - add /etc/${MY_PN}/recorder.yaml to /etc/${MY_PN}/configuration.yaml
- - mv /etc/${MY_PN}/home-assistant_v2.db /var/db/${MY_PN}
-
- support thread at:
- https://community.home-assistant.io/t/gentoo-homeassistant-0-59-2-ebuild/35577
-"
-
-S="${WORKDIR}"
-
-pkg_setup() {
- enewgroup "${MY_PN}"
- enewuser "${MY_PN}" -1 -1 "$INSTALL_DIR" "${MY_PN}"
-}
-
-src_compile() {
- true
-}
-
-src_install() {
- keepdir "$INSTALL_DIR"
-
- keepdir "/etc/${MY_PN}"
- insinto "/etc/${MY_PN}"
- doins "${FILESDIR}/recorder.yaml"
- fowners -R "${MY_PN}:${MY_PN}" "/etc/${MY_PN}"
-
- python3.5 -m venv "${D}/$INSTALL_DIR"
- # for no output from pip add: --quiet
- # note the venv has a python3, but no python3.5
- VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "${MY_PN}"
- sed -i "1c#!$INSTALL_DIR/bin/python3" "${D}/$INSTALL_DIR/bin/hass"
- fowners -R "${MY_PN}:${MY_PN}" "$INSTALL_DIR"
-
- newconfd "${FILESDIR}/${MY_PN}.conf.d" "${MY_PN}"
- newinitd "${FILESDIR}/${MY_PN}.init.d" "${MY_PN}"
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"
-
- keepdir "/var/log/${MY_PN}/old"
- fowners -R "${MY_PN}:${MY_PN}" "/var/log/${MY_PN}"
-
- keepdir "/var/db/${MY_PN}"
- fowners -R "${MY_PN}:${MY_PN}" "/var/db/${MY_PN}"
-
- systemd_dounit "${FILESDIR}"/${MY_PN}.service
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
-
-pkg_config() {
- "${INSTALL_DIR}/bin/hass" --script ensure_config
-}