aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2017-01-09 20:06:12 +0000
committerPaul Healy <lmiphay@gmail.com>2017-01-09 20:06:12 +0000
commit616ee1d1a17087228a2f63bbbce2997f78f8b553 (patch)
tree858035f1076d3fd6ebf0239f17403b295a93ca55
parentbump slack to 2.3.4 (diff)
downloadlmiphay-616ee1d1a17087228a2f63bbbce2997f78f8b553.tar.gz
lmiphay-616ee1d1a17087228a2f63bbbce2997f78f8b553.tar.bz2
lmiphay-616ee1d1a17087228a2f63bbbce2997f78f8b553.zip
add live ebuild for the Amadeus NTP-Proxy
-rw-r--r--net-misc/ntp-proxy/Manifest3
-rw-r--r--net-misc/ntp-proxy/files/ntp-proxy.conf.d6
-rwxr-xr-xnet-misc/ntp-proxy/files/ntp-proxy.init.d21
-rw-r--r--net-misc/ntp-proxy/ntp-proxy-9999.ebuild30
4 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/ntp-proxy/Manifest b/net-misc/ntp-proxy/Manifest
new file mode 100644
index 0000000..b8a1098
--- /dev/null
+++ b/net-misc/ntp-proxy/Manifest
@@ -0,0 +1,3 @@
+AUX ntp-proxy.conf.d 142 SHA256 47b3ced2c77b5730b53a8189998f1ecd1430a662bb4799cffe88a1cf9dae86ed SHA512 e090721f781f1164f282efe748687db1d98538efdfe315cd7b90832cd793c999bf5205c0ed96b347523c3f28765831401ddbf87133d97d8382e030ec873df7f5 WHIRLPOOL 08a93e3bbcb5447a0239d760055de09ece36f99d0d9dcd729f9507b2f20a1af27f41549c670c9fbdccb9f01779e181a9b364f85a2568eb407b60080af4b8f49a
+AUX ntp-proxy.init.d 450 SHA256 14bf1f8a3c6bab7ba41a949282851e3213bd6aa716b87b895f37d6a3f8048b0a SHA512 ecbb4d838041ee0abed8c1605e6d7d1cb6e5d3a2d713e461ea9933891a5e3f9d7d900831cb27f8a76dcab66d267baefe062e74876e892f81329ec99d64880c0f WHIRLPOOL b865792fd92fb98f31869947ccb00366ff2eff51c1e145fbf9cde7cbf6e1cd32f0f3b17a9f92bbd42ab7f2f7db4abc847ee245ed179918948dd7e3535c0b1ed8
+EBUILD ntp-proxy-9999.ebuild 725 SHA256 9156cdc743e93e1e0aa643bce329761307b05a39749f332710b221bf9327acbd SHA512 e23cdcf54cdd6e53644d54f04fa46f7bdd010e6bf3c1dc5bd1533ec910959800edc6fb585bc34c749240f43a8498c4d7c750d0517b6f08257f3a412ee6b21fe3 WHIRLPOOL 9acbc3e299b1e418d66dceff34664367312406e727dfa37160e3fc4cf075d8568915165425c39882fced606948491ec72ab8d00af6fc0c7b5b08f9371e0caa6b
diff --git a/net-misc/ntp-proxy/files/ntp-proxy.conf.d b/net-misc/ntp-proxy/files/ntp-proxy.conf.d
new file mode 100644
index 0000000..afd7ec5
--- /dev/null
+++ b/net-misc/ntp-proxy/files/ntp-proxy.conf.d
@@ -0,0 +1,6 @@
+# /etc/conf.d/ntp-proxy: config file for /etc/init.d/ntp-proxy
+
+# 'ntpproxy -h' for available options
+#
+NTP_PROXY_ARGS="-v -s NTP_SERVER_IP"
+
diff --git a/net-misc/ntp-proxy/files/ntp-proxy.init.d b/net-misc/ntp-proxy/files/ntp-proxy.init.d
new file mode 100755
index 0000000..6775c0a
--- /dev/null
+++ b/net-misc/ntp-proxy/files/ntp-proxy.init.d
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+description="Leap second simulation daemon"
+
+logfile="/var/log/ntp-log.log"
+
+command="/usr/sbin/ntpproxy"
+command_args="${NTP_PROXY_ARGS}"
+start_stop_daemon_args="--stdout $logfile --stderr $logfile"
+
+command_background=yes
+pidfile=/run/ntp-proxy.pid
+
+depend() {
+ need net
+ after bootmisc
+ provide ntp-proxy
+}
diff --git a/net-misc/ntp-proxy/ntp-proxy-9999.ebuild b/net-misc/ntp-proxy/ntp-proxy-9999.ebuild
new file mode 100644
index 0000000..b322312
--- /dev/null
+++ b/net-misc/ntp-proxy/ntp-proxy-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+inherit git-r3
+
+DESCRIPTION="Leap second immunity verification programs"
+HOMEPAGE="http://www.amadeus.com/web/amadeus/en_1A-corporate/Amadeus-Home/Travel-trends/Travel-technology-trends/Open-source/Our-contributions/NTP-Proxy/1319686226159-Page-AMAD_DetailPpal"
+EGIT_REPO_URI="https://github.com/AmadeusITGroup/NTP-Proxy.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-libs/libnet:1.1
+"
+DEPEND="${RDEPEND}"
+
+DOCS="README.md"
+
+src_install() {
+ dodoc ${DOCS}
+ dosbin sls ntpproxy
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+}
+