aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-04-03 21:38:54 +0100
committerPaul Healy <lmiphay@gmail.com>2018-04-03 21:38:54 +0100
commit76af19c22f08d8d1a2d71a9b4ea31e45fc51cf11 (patch)
tree6a107923adc431bd77a4f316b75399d868bc0307
parentremove old stride ebuild (diff)
downloadlmiphay-76af19c22f08d8d1a2d71a9b4ea31e45fc51cf11.tar.gz
lmiphay-76af19c22f08d8d1a2d71a9b4ea31e45fc51cf11.tar.bz2
lmiphay-76af19c22f08d8d1a2d71a9b4ea31e45fc51cf11.zip
revbump homeassistant
-rw-r--r--app-misc/homeassistant-bin/Manifest1
-rw-r--r--app-misc/homeassistant-bin/homeassistant-bin-0.66.1.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/app-misc/homeassistant-bin/Manifest b/app-misc/homeassistant-bin/Manifest
index d713943..15559aa 100644
--- a/app-misc/homeassistant-bin/Manifest
+++ b/app-misc/homeassistant-bin/Manifest
@@ -6,4 +6,5 @@ AUX update-homeassistant 1326 BLAKE2B 917bdd332c4e5dea5177eecd11a7f8d72b911fddfd
EBUILD homeassistant-bin-0.64.3.ebuild 2726 BLAKE2B 63b169410836a4f26276b7ebae2abe31f6a0a13e5f5c94f3746197f3a8bd0fe253ca05835d5398c1eb11bb8f79e5767f9ae04af77f83404e1f95e5a585e3db10 SHA512 6ec322046808999edc6a07d97cccba7b2b3da616ae1e02a17b2acf36cd526eb1677ab773f7f9a49688ec5c7b4dec9147af04921c1749bed086a9564a0eb05be8
EBUILD homeassistant-bin-0.65.3.ebuild 2751 BLAKE2B 998443da2816988e135abce3dac4805919ee8d67dc337df6104b22cc6a2b405b67bc4cb8377297e535d17b5c812a4b60dd9c374ec743c64ba49f652c38969ce7 SHA512 f21ca4aa9de921133e03b6142993551eb15a6384f8c82c2fd1a336f7482b533d0b91db325bbd040ab2df6b29e0f0ed566d2b6f28e6d1fac8bdcb732e78d76b18
EBUILD homeassistant-bin-0.65.5.ebuild 2751 BLAKE2B 998443da2816988e135abce3dac4805919ee8d67dc337df6104b22cc6a2b405b67bc4cb8377297e535d17b5c812a4b60dd9c374ec743c64ba49f652c38969ce7 SHA512 f21ca4aa9de921133e03b6142993551eb15a6384f8c82c2fd1a336f7482b533d0b91db325bbd040ab2df6b29e0f0ed566d2b6f28e6d1fac8bdcb732e78d76b18
+EBUILD homeassistant-bin-0.66.1.ebuild 2751 BLAKE2B 998443da2816988e135abce3dac4805919ee8d67dc337df6104b22cc6a2b405b67bc4cb8377297e535d17b5c812a4b60dd9c374ec743c64ba49f652c38969ce7 SHA512 f21ca4aa9de921133e03b6142993551eb15a6384f8c82c2fd1a336f7482b533d0b91db325bbd040ab2df6b29e0f0ed566d2b6f28e6d1fac8bdcb732e78d76b18
EBUILD homeassistant-bin-9999.ebuild 2528 BLAKE2B af5a3bccc5781e260ed34278ca50bfa7fe2f5d40a2e20c60aefb6b9427fa9aec122c41c06b9a690074e058b21a84e2caa76a6efa93bd4766f0e7d3d1cd750644 SHA512 1d4b4cf5ce4c352cf402194ec43f98e4bdecd79df342d2581d879702bef2c115cb7752aca90716d811f05a91839db360b6d7b65d71cdcbac5635472618d9ea2c
diff --git a/app-misc/homeassistant-bin/homeassistant-bin-0.66.1.ebuild b/app-misc/homeassistant-bin/homeassistant-bin-0.66.1.ebuild
new file mode 100644
index 0000000..602f0ea
--- /dev/null
+++ b/app-misc/homeassistant-bin/homeassistant-bin-0.66.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_5 )
+
+inherit user readme.gentoo-r1 eutils distutils-r1
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Home automation platform (Python 3 required)"
+HOMEPAGE="https://home-assistant.io"
+SRC_URI="" # pip installs HA version $PV from PyPI
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="maint"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ !app-misc/homeassistant
+ >=dev-lang/python-3.5.4
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ app-admin/logrotate
+ maint? (
+ app-crypt/certbot
+ app-crypt/ssl-cert-check
+ net-misc/dropbox-uploader
+ virtual/logger
+ )
+"
+
+INSTALL_DIR="/opt/${MY_PN}"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+ The HA interface listens on port 8123 - this _will_ take a minute or two to appear
+
+ hass configuration is in: /etc/${MY_PN}
+ daemon command line arguments are configured in: /etc/conf.d/${MY_PN}
+
+ logging is to: /var/log/${MY_PN}/{server,errors,stdout}.log
+
+ The sqlite db is by default in: /etc/${MY_PN}
+ To move it after ${MY_PN} has run once and while ${MY_PN} is stopped:
+ - add /etc/${MY_PN}/recorder.yaml to /etc/${MY_PN}/configuration.yaml
+ - mv /etc/${MY_PN}/home-assistant_v2.db /var/db/${MY_PN}
+
+ support thread at:
+ https://community.home-assistant.io/t/gentoo-homeassistant-0-59-2-ebuild/35577
+
+ The script /usr/bin/update-homeassistant can be used to update homeassistant-bin (it keeps
+ a backup of the previous virtualenv under /opt).
+"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ enewgroup "${MY_PN}"
+ enewuser "${MY_PN}" -1 -1 "$INSTALL_DIR" "${MY_PN}"
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin "${FILESDIR}/update-homeassistant"
+
+ keepdir "$INSTALL_DIR"
+
+ keepdir "/etc/${MY_PN}"
+ insinto "/etc/${MY_PN}"
+ doins "${FILESDIR}/recorder.yaml"
+ fowners -R "${MY_PN}:${MY_PN}" "/etc/${MY_PN}"
+
+ python3.5 -m venv "${D}/$INSTALL_DIR"
+ # for no output from pip add: --quiet
+ # note the venv has a python3, but no python3.5
+ VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "${MY_PN}==${PV}"
+ sed -i "1c#!$INSTALL_DIR/bin/python3" "${D}/$INSTALL_DIR/bin/hass"
+ fowners -R "${MY_PN}:${MY_PN}" "$INSTALL_DIR"
+
+ newconfd "${FILESDIR}/${MY_PN}.conf.d" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.init.d" "${MY_PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"
+
+ keepdir "/var/log/${MY_PN}/old"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/log/${MY_PN}"
+
+ keepdir "/var/db/${MY_PN}"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/db/${MY_PN}"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+pkg_config() {
+ "${INSTALL_DIR}/bin/hass" --script ensure_config
+}