aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2017-11-10 12:08:58 +0000
committerPaul Healy <lmiphay@gmail.com>2017-11-10 12:08:58 +0000
commit996d3c63d7ec84cf883cb04b7a833a4a495d993f (patch)
tree10aaac47e6bd16e4e845495e0e56cbae3850dbbd
parentupdate etags version to avoid indexing failures (diff)
downloadlmiphay-996d3c63d7ec84cf883cb04b7a833a4a495d993f.tar.gz
lmiphay-996d3c63d7ec84cf883cb04b7a833a4a495d993f.tar.bz2
lmiphay-996d3c63d7ec84cf883cb04b7a833a4a495d993f.zip
add stride ebuild - work-in-progress
-rw-r--r--net-im/stride-bin/Manifest2
-rw-r--r--net-im/stride-bin/stride-bin-1.5.18.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/net-im/stride-bin/Manifest b/net-im/stride-bin/Manifest
new file mode 100644
index 0000000..c9822d5
--- /dev/null
+++ b/net-im/stride-bin/Manifest
@@ -0,0 +1,2 @@
+DIST stride-bin-1.5.18.deb 56806824 SHA256 8e8b70f2fbe67a8eecee8a3c2a6d5a007e0dfb4542109d6dca1cb34584f867ed SHA512 618058e4ca6f90c8c2b96ee0c8a893664157cc912f0d45b5b122936c9784b5bb32befd42d79d1ab64da092e7fbc04d8099d1a92f4d57861609649b9e173f0b2c WHIRLPOOL 2862f9f64cf43eddccbc41228500d369483b65ee20d0317a0acad8612c6ec97dde53bd0df312e2de98f69207c4e0a41491ba151f52a9fb16ebd13fd99a735e67
+EBUILD stride-bin-1.5.18.ebuild 1258 SHA256 0779cb3fd374d11c0022b160fbc7dc59dceb772b23e1a827ee946cb446f5a66e SHA512 38551a8fa9ec6ae476f08f4a1def40f688d0308d2ca79e5387c12f6d1a8157968862009537a760be77d0c0bd8da9e2110d77285c33417bfdf83995d5d466952d WHIRLPOOL 2dc265a59dcf46b4029c76567499a44e4f52766c75448ae884e29ddf5351df864500c3031aa1f757368d8163ddf2ac76bc8a6985997fb254721989f5e750e6d6
diff --git a/net-im/stride-bin/stride-bin-1.5.18.ebuild b/net-im/stride-bin/stride-bin-1.5.18.ebuild
new file mode 100644
index 0000000..220e1a6
--- /dev/null
+++ b/net-im/stride-bin/stride-bin-1.5.18.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils unpacker xdg-utils xdg
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION=""
+HOMEPAGE="https://www.stride.com/"
+SRC_URI="https://stride-desktop-downloads.s3.amazonaws.com/releases/linux/deb/64/prod/stride_amd64.deb -> ${PN}-${PV}.deb"
+LICENSE="no-source-code"
+RESTRICT="mirror"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+QA_PREBUILT="opt/${PN}/*"
+
+S="${WORKDIR}/usr/lib/${MY_PN}"
+
+src_prepare() {
+ sed -i -e 's:Network;::' "${WORKDIR}/usr/share/applications/${MY_PN}.desktop"
+ eapply_user
+}
+
+src_install() {
+ exeinto "/opt/${PN}"
+ doexe "${MY_PN}"
+
+ insinto "/opt/${PN}"
+ doins *.pak *.so icudtl.dat natives_blob.bin snapshot_blob.bin version
+ doins -r locales resources
+
+ insinto /usr/share
+ doins -r "${WORKDIR}/usr/share/icons"
+
+ make_wrapper "${MY_PN}" "./${MY_PN}" "/opt/${PN}" .
+
+ domenu "${WORKDIR}/usr/share/applications/${MY_PN}.desktop"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}