aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2022-07-10 13:13:20 +0100
committerPaul Healy <lmiphay@gmail.com>2022-07-10 13:13:20 +0100
commitbb0ff7c627dd61460b411db99d5639ed9055b33a (patch)
treee40230c7d6d9dd5b70f9443811a93e0b7fa22ef4
parentupdate attridict mask (diff)
downloadlmiphay-bb0ff7c627dd61460b411db99d5639ed9055b33a.tar.gz
lmiphay-bb0ff7c627dd61460b411db99d5639ed9055b33a.tar.bz2
lmiphay-bb0ff7c627dd61460b411db99d5639ed9055b33a.zip
revbump piper; disable tests looking for appstreamcli
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--sys-apps/piper/Manifest4
-rw-r--r--sys-apps/piper/piper-0.7.ebuild (renamed from sys-apps/piper/piper-0.6.ebuild)8
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-apps/piper/Manifest b/sys-apps/piper/Manifest
index aeb55af..ff00e82 100644
--- a/sys-apps/piper/Manifest
+++ b/sys-apps/piper/Manifest
@@ -1,2 +1,2 @@
-DIST piper-0.6.tar.gz 254653 BLAKE2B ea621e556e2ee6a98e334f2e61df70d700a9cb371dcd5bddc690b4a4c97543a6957bc339bddbde2cf91ac3b201d3bd70fe336974f17e36cfdcbb4895257af993 SHA512 9d76cbc5f3a91c68d10355a1b429c05873effcaa80086fb51c7d4a7bdbbb3e0faf42ec8ccad611a15f5c954d3014a8416e4a497c86167c227818771a24d108a0
-EBUILD piper-0.6.ebuild 846 BLAKE2B 5f30f0ee9e15810d27e70d4dcf9b3cb8dde92ac4c08d93217a5d7c08bd85cff6e1156ba6091471462490aa91a74e91993ec0126f0938fef6c13e4d2f98a89957 SHA512 6c593f8086c4267a7fa7886c6fd9bf2a3120dbb96fa39065bfc8fdbb315aa1ed5d26a659a42fbf419e0801d933ab3df3520bbc7f8b3dd6f7b0734999d552ab94
+DIST piper-0.7.tar.gz 271658 BLAKE2B 8d3d411cc771a286ae0d7654b6d70f394e11edb182924619195b947d0d54df4db308e94aceebe0754ddd446538f1dce2ccb88dbf1cd44595b614d852e7394698 SHA512 fcbc30a4954ea6b0aa67c66052eab1e6b2d3039c927eeddcfc8b03d00f1c91e8f0ae80788ba0e4f053a612b03f594e74fd119dd11f52dd47608c99602e7e4940
+EBUILD piper-0.7.ebuild 903 BLAKE2B a422f80c8fecebd50aa3815f8d28349efc4bb5758b669f447788e2cdb7e4780694486cc589ffb48b1827da2660c8b5783e178b3825c0e73ca3e158c30a2fd590 SHA512 6be675ebaf8b5c3fd7ae3fa6ec1f6b5bf2eed362f2c614cb3751d14431bfa52e23ac0e2a8580c57e2a6df8f6f06b0f160e6e0c4feb039ec79240bd71340b90b3
diff --git a/sys-apps/piper/piper-0.6.ebuild b/sys-apps/piper/piper-0.7.ebuild
index 27566a5..e0d4955 100644
--- a/sys-apps/piper/piper-0.6.ebuild
+++ b/sys-apps/piper/piper-0.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_9 )
+PYTHON_COMPAT=( python3_10 )
inherit meson python-r1 xdg-utils
@@ -33,6 +33,10 @@ pkg_setup() {
python_setup
}
+src_configure() {
+ meson_src_configure -Dtests=false
+}
+
src_install() {
meson_src_install
python_optimize