aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2020-05-01 10:45:49 +0100
committerPaul Healy <lmiphay@gmail.com>2020-05-01 10:45:49 +0100
commitc902011f576be2f635d70566273cc16831af5c0e (patch)
tree073d756ca1c58a83336ac412985a50c1d2c1f18d
parentrevbump homeassistant (diff)
downloadlmiphay-c902011f576be2f635d70566273cc16831af5c0e.tar.gz
lmiphay-c902011f576be2f635d70566273cc16831af5c0e.tar.bz2
lmiphay-c902011f576be2f635d70566273cc16831af5c0e.zip
add ebuild for okteto cli
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--dev-util/okteto-bin/Manifest2
-rw-r--r--dev-util/okteto-bin/okteto-bin-1.8.5.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/okteto-bin/Manifest b/dev-util/okteto-bin/Manifest
new file mode 100644
index 0000000..ea5d8db
--- /dev/null
+++ b/dev-util/okteto-bin/Manifest
@@ -0,0 +1,2 @@
+DIST okteto-bin-1.8.5 60518400 BLAKE2B af216eac1abf5ac97ace03040cbdce0ac2beaf3dfae08ced087b3aa04cbea18e4c695af75b2dea56972aeb37ff139ae2e41fcefd4f4413f9e9151deefabab4b4 SHA512 0b535360272cda12ab5d98e1f4b61e8f0414ce9a5d752ff1f56481df5a7c9e3b6d18a6a281aa9482867c21ae41538687a57de51975e7626117f885e9d7c9b413
+EBUILD okteto-bin-1.8.5.ebuild 504 BLAKE2B 98f15f8ead073c2e2b921b7b1cba09155d93b4bdde1216e6e9cbaa0ab24eedd10bff220ee121b5ed1c029af349464072e6c7c5d17edea8bb86a92a71a09cb7b9 SHA512 28b2180cae7c8a83b0c0951f9241ef493ee3e46fad985c24970c5085d9f57dd79971edfe70099e5edaa9054ee68dad5e661661fbe536e22db528866169c6864f
diff --git a/dev-util/okteto-bin/okteto-bin-1.8.5.ebuild b/dev-util/okteto-bin/okteto-bin-1.8.5.ebuild
new file mode 100644
index 0000000..4ed29ca
--- /dev/null
+++ b/dev-util/okteto-bin/okteto-bin-1.8.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="App dev/test directly in Kubernetes"
+HOMEPAGE="https://okteto.com/"
+SRC_URI="https://github.com/okteto/okteto/releases/download/${PV}/okteto-Linux-x86_64 -> ${P}"
+RESTRICT="mirror"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+"
+DEPEND="
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ newbin "${DISTDIR}/${P}" "${MY_PN}"
+}