aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-12-12 21:59:47 +0000
committerPaul Healy <lmiphay@gmail.com>2018-12-12 21:59:47 +0000
commit62f3c3a7a03a253e7f28962d55f51a5b99fc51d6 (patch)
tree98bb8f6717c8765d5bfa8932c849836fa8f7b240 /app-emacs/lms/lms-20181212.ebuild
parentrevbump homeassistant (diff)
downloadlmiphay-62f3c3a7a03a253e7f28962d55f51a5b99fc51d6.tar.gz
lmiphay-62f3c3a7a03a253e7f28962d55f51a5b99fc51d6.tar.bz2
lmiphay-62f3c3a7a03a253e7f28962d55f51a5b99fc51d6.zip
revbump app-emacs/lms (note opt helm dep)
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'app-emacs/lms/lms-20181212.ebuild')
-rw-r--r--app-emacs/lms/lms-20181212.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/lms/lms-20181212.ebuild b/app-emacs/lms/lms-20181212.ebuild
new file mode 100644
index 0000000..391cf1f
--- /dev/null
+++ b/app-emacs/lms/lms-20181212.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 elisp
+
+HASH="f347681d0133"
+
+DESCRIPTION="Frontend for Squeezebox / Logitech Media Server"
+HOMEPAGE="https://bitbucket.org/inigoserna/lms.el"
+SRC_URI="https://bitbucket.org/inigoserna/lms.el/get/${HASH}.zip -> ${P}.zip"
+RESTRICT="mirror"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# need seq.el included in emacs 25
+DEPEND=">=app-editors/emacs-25.2"
+
+DOCS="README.org"
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="customize:
+
+ lms-hostname, lms-telnet-port, lms-html-port, lms-username, lms-password
+
+and run with: lms-ui
+
+Then read complete documentation by pressing the 'h' key
+
+For an overview of what it can do see: https://inigo.katxi.org/blog/2017/07/31/lms_el.html
+
+Support thread at: http://forums.slimdevices.com/showthread.php?107769-Announce-lms-el-a-squeezebox-controller-for-emacs
+"
+
+S="${WORKDIR}/inigoserna-${PN}.el-${HASH}"
+
+src_install() {
+ readme.gentoo_create_doc
+ elisp_src_install
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}