aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-01-17 22:17:14 +0000
committerPaul Healy <lmiphay@gmail.com>2018-01-17 22:17:14 +0000
commit076f2411143361d9d644220c22486d0d13ff4269 (patch)
tree66670b3bc573df9d361bb324c18162c1545430e1 /app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild
parentadd ebuild for release candidate 1 (diff)
downloadlmiphay-076f2411143361d9d644220c22486d0d13ff4269.tar.gz
lmiphay-076f2411143361d9d644220c22486d0d13ff4269.tar.bz2
lmiphay-076f2411143361d9d644220c22486d0d13ff4269.zip
revbump to 0.61.1; switch back to pure pip install for -bin version
Diffstat (limited to 'app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild')
-rw-r--r--app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild b/app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild
index 0a36fc4..4f03039 100644
--- a/app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild
+++ b/app-misc/homeassistant-bin/homeassistant-bin-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -61,6 +61,10 @@ pkg_setup() {
enewuser "${MY_PN}" -1 -1 "$INSTALL_DIR" "${MY_PN}"
}
+src_compile() {
+ true
+}
+
src_install() {
keepdir "$INSTALL_DIR"
@@ -94,3 +98,7 @@ src_install() {
pkg_postinst() {
readme.gentoo_print_elog
}
+
+pkg_config() {
+ "${INSTALL_DIR}/bin/hass" --script ensure_config
+}