aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2017-03-24 21:24:38 +0000
committerPaul Healy <lmiphay@gmail.com>2017-03-24 21:24:38 +0000
commit3b47825c450cd4b0055961616f7022ea6dae1e1c (patch)
treeaa633cd2987d5685b77a7e5f89641683126af7ff /app-shells
parentremove old ebuild (diff)
downloadlmiphay-3b47825c450cd4b0055961616f7022ea6dae1e1c.tar.gz
lmiphay-3b47825c450cd4b0055961616f7022ea6dae1e1c.tar.bz2
lmiphay-3b47825c450cd4b0055961616f7022ea6dae1e1c.zip
update ebuild and add a versioned option
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bashsimplecurses/Manifest3
-rw-r--r--app-shells/bashsimplecurses/bashsimplecurses-20161206.ebuild35
-rw-r--r--app-shells/bashsimplecurses/bashsimplecurses-9999.ebuild7
3 files changed, 40 insertions, 5 deletions
diff --git a/app-shells/bashsimplecurses/Manifest b/app-shells/bashsimplecurses/Manifest
index 9e5ee1f..0ac4361 100644
--- a/app-shells/bashsimplecurses/Manifest
+++ b/app-shells/bashsimplecurses/Manifest
@@ -1 +1,2 @@
-EBUILD bashsimplecurses-9999.ebuild 597 SHA256 e8f1fdc368795564416514ff1e5291607225d13e3cb8488ff42498ec04aaa70a SHA512 4ba691f83e431c8663adf26c9e075ca4c990181729bb881bbe7ca40660e019e20658dee1e5808a50784c48bd52d4f6adf28806bd6ac993773d9d276f4e32b5da WHIRLPOOL 11743aa3a383a84e226076a694975f890778b880e170316d47cda9433447097c8863a0c2a6f1a0e282cb9d7ec0efaf9360dcebaefed8b200370e3a608979ab6a
+EBUILD bashsimplecurses-20161206.ebuild 696 SHA256 d8a78beaaa3c32787fb4412c71c7ed9c1b5f680cfce4f0ee6693c3db7e7f4cc0 SHA512 7ecb5fe71cf0c7ff6597a7ffe50f8a6cb79fdf783952477c50017d279edf1cbd78d19fbc0cd5f5827286e6ede3d25c4f81dd35416decb5537e77be65af34443a WHIRLPOOL e7faed53ab8ffd7df78c0861edc1fb5c31fc054f6cb281214510100af333bde22153202d4c2e244510094ba63461cb2965a6527c1952d60db8f8911143209b46
+EBUILD bashsimplecurses-9999.ebuild 641 SHA256 67d5f66ad67b795866dcfe1109bbbae8ce4b71e3417dd9f76e3a100f8942dea5 SHA512 afd7e21f6944a9ce626e235d32dc27975e5bfa0415c1e2a0d21f0e882fb77f6ecc432d892d857d401e648a142b0dac45a9c2edc10d793fca7a70b9d2bacf2c6d WHIRLPOOL 3ff5294611d09f08444ada7dbc0ecb94d529652207f660929cf0968228f586574e765cb21ac8fa62ed10c0924b16f74f28dcf58615637acd3280512f141ed4f2
diff --git a/app-shells/bashsimplecurses/bashsimplecurses-20161206.ebuild b/app-shells/bashsimplecurses/bashsimplecurses-20161206.ebuild
new file mode 100644
index 0000000..4609e37
--- /dev/null
+++ b/app-shells/bashsimplecurses/bashsimplecurses-20161206.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Functions to create windows on Xterm, aterm, urxvt... etc"
+HOMEPAGE="https://github.com/metal3d/bashsimplecurses"
+EGIT_REPO_URI="https://github.com/metal3d/${PN}.git"
+EGIT_COMMIT="375c041b54df7454dfe5ebe299ce740c39d57f76"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libcaca
+ sys-libs/ncurses
+"
+DEPEND="${RDEPEND}
+"
+
+DOCS="README.md AUTHORS"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins simple_curses.sh
+ dodoc ${DOCS}
+}
+
+pkg_postinst() {
+ elog "See docs at: http://bashsimplecurses.readthedocs.org/en/latest/"
+}
diff --git a/app-shells/bashsimplecurses/bashsimplecurses-9999.ebuild b/app-shells/bashsimplecurses/bashsimplecurses-9999.ebuild
index 3899747..c39b3e1 100644
--- a/app-shells/bashsimplecurses/bashsimplecurses-9999.ebuild
+++ b/app-shells/bashsimplecurses/bashsimplecurses-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=5
+EAPI=6
inherit git-r3
-DESCRIPTION=""
+DESCRIPTION="Functions to create windows on Xterm, aterm, urxvt... etc"
HOMEPAGE="https://github.com/metal3d/bashsimplecurses"
EGIT_REPO_URI="https://github.com/metal3d/${PN}.git"