aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-08-06 16:58:21 +0100
committerPaul Healy <lmiphay@gmail.com>2018-08-06 16:58:21 +0100
commit6b24505d9ba19c41388f52ac234754f12ac5909c (patch)
tree6e6a1ec86cb0a40c0b69e1324e034d461b5802cd /dev-lsl
parentadd dev-lsl as a category (diff)
downloadlmiphay-6b24505d9ba19c41388f52ac234754f12ac5909c.tar.gz
lmiphay-6b24505d9ba19c41388f52ac234754f12ac5909c.tar.bz2
lmiphay-6b24505d9ba19c41388f52ac234754f12ac5909c.zip
add ebuild for lslint
Diffstat (limited to 'dev-lsl')
-rw-r--r--dev-lsl/lslint/Manifest2
-rw-r--r--dev-lsl/lslint/lslint-1.1.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-lsl/lslint/Manifest b/dev-lsl/lslint/Manifest
new file mode 100644
index 0000000..7c88d13
--- /dev/null
+++ b/dev-lsl/lslint/Manifest
@@ -0,0 +1,2 @@
+DIST lslint-1.1.1.tar.gz 133237 BLAKE2B 13a883a823eb52cd3ad8d99a3191262c02b63524f9e28d9f4eb55723ee7354705132407f2899adfb62a2a4457de369a36db98aeac93eba267a13c51984b73bac SHA512 e03a7f932734fd44fc8e0ba4f6fcfa1bd8a2102914392cfcbaa6a5663514abd14b288f7ae3e1cb2e317a9359f716ff5c6cda505e45e86943e3636b002982994d
+EBUILD lslint-1.1.1.ebuild 895 BLAKE2B d004631c9b20d5ad83891a919f7b9fb6a4309789bb13c07b8aaf261f824566ae58f89890908df497b020b0fb6373b7661c4e68f7a544456b123457f5ad6b879a SHA512 91cbf711319556a19b2ba9761ca49671e64c3f3b161cfe95e426ccaeb08b6216f4f01f04041d8d3bcdb8690df81a55b6ffe399a63668bb35751d4ca38d97e6d2
diff --git a/dev-lsl/lslint/lslint-1.1.1.ebuild b/dev-lsl/lslint/lslint-1.1.1.ebuild
new file mode 100644
index 0000000..ae5f723
--- /dev/null
+++ b/dev-lsl/lslint/lslint-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="A tool to check the validity of Second Life LSL scripts"
+HOMEPAGE="http://w-hat.com/#lslint"
+SRC_URI="https://github.com/Makopo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i -e 's:CXX = g++ -g -Wall -std=c++98 -pedantic-errors -fno-omit-frame-pointer -ffloat-store:MYCXXFLAGS = -Wall -std=c++98 -pedantic-errors:' Makefile
+ sed -i -e 's:CXX += -arch i386 -arch ppc::' Makefile
+ sed -i -e 's:CXX += -arch i386::' Makefile
+ sed -i -e 's:$(CXX) $(CXXFLAGS):$(CXX) $(CXXFLAGS) $(MYCXXFLAGS):' Makefile
+
+ sed -i -e 's:$(LD) $(LDFLAGS):$(CXX) $(LDFLAGS):' Makefile
+
+ eapply_user
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}