aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-10-09 21:23:37 +0100
committerPaul Healy <lmiphay@gmail.com>2018-10-09 21:23:37 +0100
commitf6ea2e8451fc68617f38628b318b000d64f70a0d (patch)
treed6894b87a057ab82db27bb4dbb860300528ec7cb /www-apps
parentremove old opengrok ebuilds (diff)
downloadlmiphay-f6ea2e8451fc68617f38628b318b000d64f70a0d.tar.gz
lmiphay-f6ea2e8451fc68617f38628b318b000d64f70a0d.tar.bz2
lmiphay-f6ea2e8451fc68617f38628b318b000d64f70a0d.zip
revbump gitea
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.5.2.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 35df095..03dc293 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -4,4 +4,6 @@ AUX gitea.initd-r1 688 BLAKE2B eb2341dee53f3fd92c49137855615d9ae7ca77efc396e2d2e
AUX gitea.logrotated 87 BLAKE2B 373830ddd6eed0ce2f0f7b1dab14e4a253e5a56a73f477cfadbc6deec373846d4df2d697735391581771699d5a6513acb0e14a446873de01eba10d19e3a6bd88 SHA512 798f3fc33026f19dd31ffa78b9b1ed313d7b82b19c047f509e896c1798b2925a1bb7c4998d98a6b47e728979bf7132fb1c2a80eb7fda096a763d6791631cb6d4
AUX gitea.service 472 BLAKE2B 4c728e2987d0c0a86e65d4b9c1a59f6193ff8a3f9b066991a06f495ad1c5586b3497c71fca1cce5b65f167af09343e7bf3215ee5e8fdefa539e384198d2d88d6 SHA512 6666fe3b4cdbb78a58db4a6bf47a15e6be9ab30b666c6eb77a9e8a002d8c0abd510fc75ef463a11ee6892ab12c98943774616072cb64fd9f2fa42ff8f676aa95
DIST gitea-1.5.1.tar.gz 18843260 BLAKE2B 0c9e0e82de91938c6c8e64a2b3ff56d16a5bdde105e934dd29923f99185e924493239c00dab5fb1af83e3973be23f2e53729831a77a509bd626d4796ba794e56 SHA512 16d10d98caf377d3bd5b4933316290e853a8fc46f5fdb3c206b9607750b5bdbdfd5c50bf8dd59906d7476d0e9211a67332eb4b780d8d37cdfb1c0bc3141ceed7
+DIST gitea-1.5.2.tar.gz 18866286 BLAKE2B a9a31fa6a310dcb6debd9399f234262214021d72adda52af959e6d9d692d5902ff6955a9802bf60212cecb2a0146c4905952d44643aa83e49c645d32541907c2 SHA512 ef91c881b3cb81d79d182b78c95624f24d63e21daa2d6e561fca79edba0ad588fae7c55503f900a8f05c566ed3bff92a9c4385fc7e5c701a80749d2a8c58b599
EBUILD gitea-1.5.1.ebuild 1892 BLAKE2B 09a05d287962d04ac368be5a9a20f65d1310231a55e90e10fb3dc9d2da79aaf94a16bf24a1f4d6be7cc27be4130a7e2edcf91fc05cad6c20077a98c09123e3b7 SHA512 aa22f9c026cb5741679c1fa8783ac9aceb1ff413d96e4a422e7f21ae5fd4ab12872b330fd58b790a9cfcf121a519a73a44016270a6919b1cd076a6ca70693998
+EBUILD gitea-1.5.2.ebuild 1892 BLAKE2B 09a05d287962d04ac368be5a9a20f65d1310231a55e90e10fb3dc9d2da79aaf94a16bf24a1f4d6be7cc27be4130a7e2edcf91fc05cad6c20077a98c09123e3b7 SHA512 aa22f9c026cb5741679c1fa8783ac9aceb1ff413d96e4a422e7f21ae5fd4ab12872b330fd58b790a9cfcf121a519a73a44016270a6919b1cd076a6ca70693998
diff --git a/www-apps/gitea/gitea-1.5.2.ebuild b/www-apps/gitea/gitea-1.5.2.ebuild
new file mode 100644
index 0000000..41abc1c
--- /dev/null
+++ b/www-apps/gitea/gitea-1.5.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user systemd golang-build golang-vcs-snapshot
+
+EGO_PN="code.gitea.io/gitea"
+KEYWORDS="~amd64 ~arm"
+
+DESCRIPTION="A painless self-hosted Git service, written in Go"
+HOMEPAGE="https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-go/go-bindata"
+RDEPEND="dev-vcs/git"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitea git
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
+ -e "s/-ldflags '-s/-ldflags '/" src/${EGO_PN}/Makefile || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
+ TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="-fno-PIC" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin gitea
+ insinto /var/lib/gitea/conf
+ newins custom/conf/app.ini.sample app.ini.example
+ popd || die
+ newinitd "${FILESDIR}"/gitea.initd-r1 gitea
+ newconfd "${FILESDIR}"/gitea.confd gitea
+ keepdir /var/log/gitea /var/lib/gitea/data
+ fowners -R git:git /var/log/gitea /var/lib/gitea/
+ systemd_dounit "${FILESDIR}/gitea.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
+ elog "No app.ini found, copying initial config over"
+ cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
+ chown git:git /var/lib/gitea/conf/app.ini
+ else
+ elog "app.ini found, please check example file for possible changes"
+ ewarn "Please note that environment variables have been changed:"
+ ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
+ ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
+ fi
+}