aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/homeassistant-bin/Manifest1
-rw-r--r--app-misc/homeassistant-bin/homeassistant-bin-0.83.2.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/app-misc/homeassistant-bin/Manifest b/app-misc/homeassistant-bin/Manifest
index 373571b..cd5a0e4 100644
--- a/app-misc/homeassistant-bin/Manifest
+++ b/app-misc/homeassistant-bin/Manifest
@@ -8,4 +8,5 @@ EBUILD homeassistant-bin-0.81.6.ebuild 2873 BLAKE2B 8bcbcfff6b2613a00714c06588b4
EBUILD homeassistant-bin-0.82.0.ebuild 2873 BLAKE2B 8bcbcfff6b2613a00714c06588b4292268d84feca3f34a665243dc541e57322a5754b1fb71a3841e7d35aafb6b3acdf3d3dfd3b468caec159408016b4a2dd22a SHA512 452fce27032fb1e60309663b85285ee8baaad1b0665c9121a149fda8a9ac72e9fa7d2ee4d477b4346debd3feb961824e7bb4d90a58f4c504eb89b8b5f8fa6643
EBUILD homeassistant-bin-0.82.1.ebuild 2873 BLAKE2B 8bcbcfff6b2613a00714c06588b4292268d84feca3f34a665243dc541e57322a5754b1fb71a3841e7d35aafb6b3acdf3d3dfd3b468caec159408016b4a2dd22a SHA512 452fce27032fb1e60309663b85285ee8baaad1b0665c9121a149fda8a9ac72e9fa7d2ee4d477b4346debd3feb961824e7bb4d90a58f4c504eb89b8b5f8fa6643
EBUILD homeassistant-bin-0.83.0.ebuild 2873 BLAKE2B 8bcbcfff6b2613a00714c06588b4292268d84feca3f34a665243dc541e57322a5754b1fb71a3841e7d35aafb6b3acdf3d3dfd3b468caec159408016b4a2dd22a SHA512 452fce27032fb1e60309663b85285ee8baaad1b0665c9121a149fda8a9ac72e9fa7d2ee4d477b4346debd3feb961824e7bb4d90a58f4c504eb89b8b5f8fa6643
+EBUILD homeassistant-bin-0.83.2.ebuild 2873 BLAKE2B 8bcbcfff6b2613a00714c06588b4292268d84feca3f34a665243dc541e57322a5754b1fb71a3841e7d35aafb6b3acdf3d3dfd3b468caec159408016b4a2dd22a SHA512 452fce27032fb1e60309663b85285ee8baaad1b0665c9121a149fda8a9ac72e9fa7d2ee4d477b4346debd3feb961824e7bb4d90a58f4c504eb89b8b5f8fa6643
EBUILD homeassistant-bin-9999.ebuild 2566 BLAKE2B 8bc81f53fb3cb8744ac59aa48c14e01d442a48fde8ed408b72922f6c921f81b6cacf4ce759a256f720c14416eaf3a62d92bf1f26c1f28919b90743d088908df2 SHA512 cd28376bdc8f7cc988a1ed01e84a03ac4de8bf843a1169ca87ab4e1d9c116a30abec36dc049e34058455e27c7ae96ae6587ac4b13a122565bae7cc718ed990c4
diff --git a/app-misc/homeassistant-bin/homeassistant-bin-0.83.2.ebuild b/app-misc/homeassistant-bin/homeassistant-bin-0.83.2.ebuild
new file mode 100644
index 0000000..3cc5fb4
--- /dev/null
+++ b/app-misc/homeassistant-bin/homeassistant-bin-0.83.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+
+inherit user readme.gentoo-r1 eutils distutils-r1 systemd
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Home automation platform (Python 3 required)"
+HOMEPAGE="https://home-assistant.io"
+SRC_URI="" # pip installs HA version $PV from PyPI
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="maint"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ !app-misc/homeassistant
+ >=dev-lang/python-3.5.4
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ app-admin/logrotate
+ maint? (
+ app-crypt/certbot
+ app-crypt/ssl-cert-check
+ net-misc/dropbox-uploader
+ virtual/logger
+ )
+"
+
+INSTALL_DIR="/opt/${MY_PN}"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="
+ The HA interface listens on port 8123 - this _will_ take a minute or two to appear
+
+ hass configuration is in: /etc/${MY_PN}
+ For openrc daemon command line arguments are configured in: /etc/conf.d/${MY_PN}
+
+ logging is to: /var/log/${MY_PN}/{server,errors,stdout}.log
+
+ The sqlite db is by default in: /etc/${MY_PN}
+ To move it after ${MY_PN} has run once and while ${MY_PN} is stopped:
+ - add /etc/${MY_PN}/recorder.yaml to /etc/${MY_PN}/configuration.yaml
+ - mv /etc/${MY_PN}/home-assistant_v2.db /var/db/${MY_PN}
+
+ support thread at:
+ https://community.home-assistant.io/t/gentoo-homeassistant-0-59-2-ebuild/35577
+
+ The script /usr/bin/update-homeassistant can be used to update homeassistant-bin (it keeps
+ a backup of the previous virtualenv under /opt). The script is for openrc only at the moment.
+"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ enewgroup "${MY_PN}"
+ enewuser "${MY_PN}" -1 -1 "$INSTALL_DIR" "${MY_PN}"
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin "${FILESDIR}/update-homeassistant"
+
+ keepdir "$INSTALL_DIR"
+
+ keepdir "/etc/${MY_PN}"
+ insinto "/etc/${MY_PN}"
+ doins "${FILESDIR}/recorder.yaml"
+ fowners -R "${MY_PN}:${MY_PN}" "/etc/${MY_PN}"
+
+ python3.5 -m venv "${D}/$INSTALL_DIR"
+ # for no output from pip add: --quiet
+ # note the venv has a python3, but no python3.5
+ VIRTUAL_ENV="$INSTALL_DIR" "${D}/$INSTALL_DIR/bin/python3" -m pip --no-cache-dir install "${MY_PN}==${PV}"
+ sed -i "1c#!$INSTALL_DIR/bin/python3" "${D}/$INSTALL_DIR/bin/hass"
+ fowners -R "${MY_PN}:${MY_PN}" "$INSTALL_DIR"
+
+ newconfd "${FILESDIR}/${MY_PN}.conf.d" "${MY_PN}"
+ newinitd "${FILESDIR}/${MY_PN}.init.d" "${MY_PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"
+
+ keepdir "/var/log/${MY_PN}/old"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/log/${MY_PN}"
+
+ keepdir "/var/db/${MY_PN}"
+ fowners -R "${MY_PN}:${MY_PN}" "/var/db/${MY_PN}"
+
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+pkg_config() {
+ "${INSTALL_DIR}/bin/hass" --script ensure_config
+}