aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tinydtls/tinydtls-9999.ebuild')
-rw-r--r--dev-python/tinydtls/tinydtls-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/tinydtls/tinydtls-9999.ebuild b/dev-python/tinydtls/tinydtls-9999.ebuild
new file mode 100644
index 0000000..8bdaf73
--- /dev/null
+++ b/dev-python/tinydtls/tinydtls-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python3_4)
+
+inherit eutils autotools distutils-r1 flag-o-matic git-r3
+
+DESCRIPTION="tinydtls for Cython"
+HOMEPAGE="https://git.fslab.de/jkonra2m/tinydtls"
+EGIT_REPO_URI="https://git.fslab.de/jkonra2m/tinydtls.git"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+DOCS="README"
+
+# install recipe taken from:
+# https://github.com/ggravlingen/pytradfri/blob/master/script/install-aiocoap.sh
+
+CYTHONSRC="${WORKDIR}/${P}/cython"
+
+python_prepare() {
+ eautoreconf
+}
+
+python_configure() {
+ econf \
+ --with-ecc \
+ --without-debug
+}
+
+python_compile() {
+ append-flags "-I${WORKDIR}/${P}-python3_4 -I${WORKDIR}/${P}-python3_4/sha2"
+ (cd "${CYTHONSRC}" && esetup.py build)
+}
+
+python_install() {
+ (cd "${CYTHONSRC}" && esetup.py install)
+}