summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Cooper <gentoo@lakedaemon.net>2012-10-21 21:35:06 -0400
committerJason Cooper <gentoo@lakedaemon.net>2012-10-21 21:35:06 -0400
commitf7aace0f7fb73efd01d4f5a02f962a7952c6c1fb (patch)
tree8ea32832709804573fed19525d3c5b432b9bb61f /app-text/tree/tree-1.6.0-r2.ebuild
parentinitial commit: logan repo (diff)
downloadlogan-f7aace0f7fb73efd01d4f5a02f962a7952c6c1fb.tar.gz
logan-f7aace0f7fb73efd01d4f5a02f962a7952c6c1fb.tar.bz2
logan-f7aace0f7fb73efd01d4f5a02f962a7952c6c1fb.zip
app-text/tree: build on ~x64-macos
Signed-off-by: Jason Cooper <gentoo@lakedaemon.net>
Diffstat (limited to 'app-text/tree/tree-1.6.0-r2.ebuild')
-rw-r--r--app-text/tree/tree-1.6.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/tree/tree-1.6.0-r2.ebuild b/app-text/tree/tree-1.6.0-r2.ebuild
new file mode 100644
index 0000000..de4e738
--- /dev/null
+++ b/app-text/tree/tree-1.6.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tree/tree-1.6.0-r1.ebuild,v 1.11 2012/08/20 01:40:20 ottxor Exp $
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files."
+HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
+SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e 's:LINUX:__linux__:' tree.c \
+ || die "sed failed"
+ mv doc/tree.1.fr doc/tree.fr.1
+}
+
+src_compile() {
+ [[ "${CHOST}" == *-darwin* ]] && epatch "${FILESDIR}"/tree-Makefile.patch
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ XOBJS="$(use elibc_uclibc && echo strverscmp.o)"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ dodoc CHANGES README*
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}