summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tree/tree-1.6.0-r2.ebuild')
-rw-r--r--app-text/tree/tree-1.6.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/tree/tree-1.6.0-r2.ebuild b/app-text/tree/tree-1.6.0-r2.ebuild
new file mode 100644
index 0000000..de4e738
--- /dev/null
+++ b/app-text/tree/tree-1.6.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tree/tree-1.6.0-r1.ebuild,v 1.11 2012/08/20 01:40:20 ottxor Exp $
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files."
+HOMEPAGE="http://mama.indstate.edu/users/ice/tree/"
+SRC_URI="ftp://mama.indstate.edu/linux/tree/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e 's:LINUX:__linux__:' tree.c \
+ || die "sed failed"
+ mv doc/tree.1.fr doc/tree.fr.1
+}
+
+src_compile() {
+ [[ "${CHOST}" == *-darwin* ]] && epatch "${FILESDIR}"/tree-Makefile.patch
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ XOBJS="$(use elibc_uclibc && echo strverscmp.o)"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ dodoc CHANGES README*
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}