summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opensg/opensg-2.0_alpha2284.ebuild')
-rw-r--r--media-libs/opensg/opensg-2.0_alpha2284.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/opensg/opensg-2.0_alpha2284.ebuild b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
new file mode 100644
index 0000000..1cbebfe
--- /dev/null
+++ b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSG is a portable scenegraph system to create realtime graphics programs, e.g. for virtual reality applications."
+HOMEPAGE="http://www.opensg.org/"
+
+SRC_URI="http://vision.ee.ethz.ch/shaegler/gentoo/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+SLOT="2"
+KEYWORDS="~x86"
+
+IUSE="tests doc examples"
+DEPEND="virtual/opengl
+ media-libs/freeglut
+ media-libs/glew
+
+ sys-devel/flex
+ sys-devel/bison
+
+ dev-libs/boost
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/openexr
+ sci-libs/gdal
+
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+
+ sci-libs/vtk
+
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${DEPEND}"
+
+EPATCH_OPTS="-p1"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-gdal-png.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DOSG_USE_OSGSUPPORT_LIBS=OFF
+ -DBOOST_ROOT=/usr
+ -DOSG_DOXY_DOC_TYPE=User
+ -DOSGBUILD_EXAMPLES_SIMPLE=ON
+ -DOSGBUILD_EXAMPLES_ADVANCED=ON
+ -DCOLLADA_ROOT_DIR=/opt/collada-dom
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake Doc || die "building documentation failed"
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"/Doc
+ dohtml -r html/* || die "dohtml failed"
+ fi
+ if use examples; then
+ cd "${CMAKE_BUILD_DIR}"/demos
+ dobin mandelbrot/mandelbrot opengl/quaternion_demo || die "dobin failed"
+ fi
+}