summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Willich <sabotageandi@gmail.com>2011-08-06 22:56:54 +0200
committerAndreas Willich <sabotageandi@gmail.com>2011-08-06 22:56:54 +0200
commit05e2888845ef46a6851eeb8817811e7f2a5172f1 (patch)
tree01f71afdf31b80285ceaec7fe6dbb4f05a430ce5 /x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild
downloadsabotageandi-05e2888845ef46a6851eeb8817811e7f2a5172f1.tar.gz
sabotageandi-05e2888845ef46a6851eeb8817811e7f2a5172f1.tar.bz2
sabotageandi-05e2888845ef46a6851eeb8817811e7f2a5172f1.zip
ebuild push
Diffstat (limited to 'x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild')
-rw-r--r--x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild b/x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild
new file mode 100644
index 0000000..4051a0f
--- /dev/null
+++ b/x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION=""
+HOMEPAGE="http://http://nuicode.com/projects/ccv"
+SRC_URI="amd64? ( http://nuicode.com/attachments/download/186/ccv-1.4.0-lin-64-bin.tar.gz )
+ x86? ( http://nuicode.com/attachments/download/184/ccv-1.4-lin-32-bin.tar.gz
+ )"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+
+RDEPEND=""
+
+#S=${WORKDIR}
+
+src_unpack() {
+ unpack "${A}"
+
+ EXTRACT_DIR=${WORKDIR}
+
+ if use amd64 ; then
+ EXTRACT_DIR=${WORKDIR}/ccv-1.4.0-lin-64-bin
+ fi
+
+ if use x86 ; then
+ EXTRACT_DIR=${WORKDIR}/ccv-1.4.lin-bin
+ fi
+
+ mv ${EXTRACT_DIR}/* ${WORKDIR}
+
+ rmdir ${EXTRACT_DIR}
+}
+
+src_install() {
+ insinto /opt/ccv
+
+ doins -r * || die
+
+ fperms 0755 /opt/ccv/clickToLaunchApp.sh
+ fperms 0755 /opt/ccv/Community_Core_Vision/clickToLaunchApp.sh
+ fperms 0755 /opt/ccv/Community_Core_Vision/Community_Core_Vision
+}
+