summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 18:25:46 -0600
committerDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 18:25:46 -0600
commit53aa9527792122cd9f398e26b9a6ee7da22f6c5c (patch)
treee642e43b4b2f4e7fec4e7aa5d48d338abb7496e5 /app-admin/rcm/rcm-1.3.0.ebuild
parentAdded hg-git 0.8.4 ebuild (diff)
downloadtriquetra-53aa9527792122cd9f398e26b9a6ee7da22f6c5c.tar.gz
triquetra-53aa9527792122cd9f398e26b9a6ee7da22f6c5c.tar.bz2
triquetra-53aa9527792122cd9f398e26b9a6ee7da22f6c5c.zip
Added ebuilds for rcm
Diffstat (limited to 'app-admin/rcm/rcm-1.3.0.ebuild')
-rw-r--r--app-admin/rcm/rcm-1.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/rcm/rcm-1.3.0.ebuild b/app-admin/rcm/rcm-1.3.0.ebuild
new file mode 100644
index 0000000..d1e71df
--- /dev/null
+++ b/app-admin/rcm/rcm-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Copyright 2014 Anton Ilin
+# Distributed under the terms of the MIT LICENSE
+# $Header: $
+
+EAPI=5
+
+inherit autotools eutils git-2
+
+DESCRIPTION="Management suite for dotfiles"
+HOMEPAGE="https://github.com/thoughtbot/rcm"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+EGIT_REPO_URI="https://github.com/thoughtbot/rcm.git"
+EGIT_COMMIT="v${PV}"
+
+DEPEND="dev-ruby/mustache"
+
+src_prepare() {
+ eautoreconf
+ maint/autocontrib man/rcm.7.mustache
+}
+
+src_configure() {
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+