summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoel Darlow <mail@mcgruff.plus.com>2012-05-29 02:45:41 +0100
committerNoel Darlow <mail@mcgruff.plus.com>2012-05-29 02:45:41 +0100
commite547f51b97c654b7315e51ff81cfc94c7f0d656d (patch)
tree7bdd923d0d762c62436db86ec75123a9adb07e45 /app-admin/gentool
parentpvr fix (diff)
downloadunderlay-e547f51b97c654b7315e51ff81cfc94c7f0d656d.tar.gz
underlay-e547f51b97c654b7315e51ff81cfc94c7f0d656d.tar.bz2
underlay-e547f51b97c654b7315e51ff81cfc94c7f0d656d.zip
several upates: tidying up ebuilds, changes to bst assertion args
Diffstat (limited to 'app-admin/gentool')
-rw-r--r--app-admin/gentool/Manifest4
-rw-r--r--app-admin/gentool/gentool-0.2.2.ebuild46
-rw-r--r--app-admin/gentool/gentool-0.2.3.ebuild39
3 files changed, 41 insertions, 48 deletions
diff --git a/app-admin/gentool/Manifest b/app-admin/gentool/Manifest
index b935e91..71d9a9c 100644
--- a/app-admin/gentool/Manifest
+++ b/app-admin/gentool/Manifest
@@ -1,4 +1,4 @@
-DIST gentool-0.2.2.tar.bz2 8567 RMD160 fe70235e9faf28c98ec8f3cea96a8ae51189cb78 SHA1 62f32d5f029ef132ef99a9b3c4dc9299f01f7e03 SHA256 1beb7575a0f156a9f01cbdb8320bf8f7093b0327d75ad8dda01c45f0b6167f5b
-EBUILD gentool-0.2.2.ebuild 1251 RMD160 fa4f6c8140703747a89ac8a354c8376e60277080 SHA1 fbeda30c400e680687fba409049fdab8a270e621 SHA256 b9d3f30f608f5a18a47a10017f8b949b3a288ef11a8518382fb99d7126823740
+DIST gentool-0.2.3.tar.bz2 8565 RMD160 8e84f862253871a34a961c190e3511581882a9e4 SHA1 b85bf285c2c3d33345317b547658bd6d31100344 SHA256 18439d5a8bde070dd789ff4f02aa99a344ecaf913f38ec1e6ac805bb02e3f191
+EBUILD gentool-0.2.3.ebuild 820 RMD160 1d09b4b1c2f6a70e99398c9eaba5899654f5dca2 SHA1 490a91b4ffd1d2ff1875fd4a40d2fd9374f955f3 SHA256 73ceef44d22e4923e3053f7213b41dce6f8f774b063fc2b009676877e8315fc1
MISC ChangeLog 0 RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 SHA1 da39a3ee5e6b4b0d3255bfef95601890afd80709 SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
MISC metadata.xml 513 RMD160 5ccacd7985a83578b1b02f37e5321fce4c75f73f SHA1 891e34ce89792243996e4c8319d1508964b096df SHA256 503e044c2881c5f53de73bcff9fd25d8c097182434c636e2614538d0f568bc53
diff --git a/app-admin/gentool/gentool-0.2.2.ebuild b/app-admin/gentool/gentool-0.2.2.ebuild
deleted file mode 100644
index 6296f4b..0000000
--- a/app-admin/gentool/gentool-0.2.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-EAPI=2
-inherit eutils
-DESCRIPTION="gentoo system management"
-HOMEPAGE=""
-SRC_URI="http://www.aperiplus.co.uk/downloads/src/${P}.tar.bz2"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE=""
-
-#DEPEND=""
-
-RDEPEND="net-misc/rsync
- sys-boot/grub
- >=app-misc/bashfun-0.1.4
- net-misc/htpdate"
-
-src_install() {
- dodir '/opt/gentool' || die "out of cheese error 1"
- insinto '/opt/gentool' || die "out of cheese error 2"
- cp -ar ${S}'/opt/gentool/'* ${D}'/opt/gentool/' || die "out of cheese error 3"
- dodir '/etc/gentool' || die "out of cheese error 4"
- insinto '/etc/gentool' || die "out of cheese error 5"
- doins ${S}'/etc/gentool/config.sh' || die "out of cheese error 6"
- doenvd ${S}'/etc/env.d/99gentool-env' || die "out of cheese error 7"
-}
-
-pkg_postinst() {
- if [ ! -f /opt/bin/gentool ]
- then
- cd /opt/bin
- ln -s /opt/gentool/bin/gentool.sh gentool
- fi
-
- path_minus_opt_bin=`echo $PATH | sed 's~/opt/bin:~~g'`
- if [ $PATH = $path_minus_opt_bin ]
- then
- ewarn
- ewarn '/opt/bin is not in your $PATH!'
- ewarn '(gentool is installed at /opt/bin/gentool)'
- ewarn
- fi
- ewarn
- ewarn 'you may want to edit /etc/gentool/config.sh now - just follow instructions in the file'
- ewarn
-}
diff --git a/app-admin/gentool/gentool-0.2.3.ebuild b/app-admin/gentool/gentool-0.2.3.ebuild
new file mode 100644
index 0000000..51131fa
--- /dev/null
+++ b/app-admin/gentool/gentool-0.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="gentoo system management"
+HOMEPAGE=""
+SRC_URI="http://www.aperiplus.co.uk/downloads/src/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-misc/bashfun-0.1.4
+ net-misc/htpdate
+ net-misc/rsync
+ sys-boot/grub"
+
+#DEPEND=""
+
+src_install() {
+ dosym /opt/gentool/bin/gentool.sh /opt/bin/gentool
+ insinto '/opt/gentool'
+ doins -r "${S}/opt/gentool"
+ dodir '/etc/gentool'
+ insinto '/etc/gentool'
+ doins "${S}/etc/gentool/config.sh"
+ doenvd "${S}/etc/env.d/99gentool-env"
+}
+
+pkg_postinst() {
+ elog
+ elog 'you may want to edit /etc/gentool/config.sh now - just follow instructions in the file'
+ elog
+}