aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Martins <leonardo@venidera.com>2012-04-24 14:42:23 -0300
committerLeonardo Martins <leonardo@venidera.com>2012-04-24 14:42:23 -0300
commita543cf0d8dc383be15010086c30e70ad04afa6af (patch)
treeee8e4718d03149d6bf19a2769d21715bad4b2e7b /dev-db/neo4j-community/neo4j-community-1.7.ebuild
parentRenamed dev-db/neo4j-community to dev-db/neo4j (diff)
downloadvenidera-a543cf0d8dc383be15010086c30e70ad04afa6af.tar.gz
venidera-a543cf0d8dc383be15010086c30e70ad04afa6af.tar.bz2
venidera-a543cf0d8dc383be15010086c30e70ad04afa6af.zip
Renamed package dev-db/neo4j back to dev-db/neo4j-community for the sake of simplicity
Diffstat (limited to 'dev-db/neo4j-community/neo4j-community-1.7.ebuild')
-rw-r--r--dev-db/neo4j-community/neo4j-community-1.7.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/neo4j-community/neo4j-community-1.7.ebuild b/dev-db/neo4j-community/neo4j-community-1.7.ebuild
new file mode 100644
index 0000000..6cdf712
--- /dev/null
+++ b/dev-db/neo4j-community/neo4j-community-1.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Neo4j is a high-performance, NOSQL graph database with all the features of a mature and robust database."
+HOMEPAGE="http://neo4j.org/"
+SRC_URI="http://dist.neo4j.org/${PN}-community-${PV}-unix.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="!dev-db/neo4j-advanced
+ !dev-db/neo4j-enterprise
+ >=virtual/jre-1.6
+ sys-process/lsof"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_install() {
+ exeinto /opt/neo4j/bin
+ doexe "${S}"/bin/neo4j || die
+ doexe "${S}"/bin/neo4j-shell || die
+ doexe "${S}"/bin/utils || die
+
+ # system requirements
+ insinto /opt/neo4j/system/lib
+ doins "${S}"/system/lib/*.jar || die
+
+ # components directory
+ insinto /opt/neo4j/lib
+ doins "${S}"/lib/*.jar || die
+
+ # plugins directory
+ dodir /opt/neo4j/plugins || die
+
+ # config files
+ insinto /etc/neo4j
+ doins "${S}"/conf/neo4j-wrapper.conf || die
+ doins "${S}"/conf/neo4j.properties || die
+ doins "${S}"/conf/neo4j-server.properties || die
+ doins "${S}"/conf/logging.properties || die
+
+ # documentation
+ dodoc "${S}"/*.txt
+ dodoc -r "${S}"/doc/*
+
+ # init script
+ newinitd "${FILESDIR}"/neo4j.init neo4j || die
+
+ # create symlinks
+ dosym /opt/neo4j/bin/neo4j /opt/bin/neo4j || die
+ dosym /opt/neo4j/bin/neo4j-shell /opt/bin/neo4j-shell || die
+}