summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Phillips <write2david@gmail.com>2012-02-03 22:27:19 -0600
committerDavid Phillips <write2david@gmail.com>2012-02-03 22:27:19 -0600
commit4a8b18008ad010d460f18a5b70f8f7a8e66ac975 (patch)
tree3c14d89a3c86eb949fe93ca043692200eb94a437 /x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
parentAdding easystroke (diff)
downloadwrite2David-4a8b18008ad010d460f18a5b70f8f7a8e66ac975.tar.gz
write2David-4a8b18008ad010d460f18a5b70f8f7a8e66ac975.tar.bz2
write2David-4a8b18008ad010d460f18a5b70f8f7a8e66ac975.zip
Adding live ebuilds cairo-dock&cairo-dock-plugins
Diffstat (limited to 'x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild')
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
new file mode 100644
index 0000000..d0f29cd
--- /dev/null
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+EBZR_REPO_URI="lp:cairo-dock-plug-ins"
+#EBZR_REVISION="2242"
+
+
+inherit cmake-utils bzr
+
+DESCRIPTION="Official plugins for cairo-dock"
+HOMEPAGE="https://launchpad.net/cairo-dock-plug-ins/"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="alsa exif gmenu terminal vala webkit xfce xgamma xklavier"
+
+RDEPEND="
+ ~x11-misc/cairo-dock-${PV}
+ alsa? ( media-libs/alsa-lib )
+ exif? ( media-libs/libexif )
+ gmenu? ( gnome-base/gnome-menus )
+ terminal? ( x11-libs/vte )
+ webkit? ( >=net-libs/webkit-gtk-1.0 )
+ xfce? ( xfce-base/thunar )
+ xgamma? ( x11-libs/libXxf86vm )
+ xklavier? ( x11-libs/libxklavier )
+ vala? ( dev-lang/vala:0.12 )
+"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
+"
+
+
+pkg_setup()
+{
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, SO IT MAY NOT BUILD RIGHT!"
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ ewarn "Please report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+}
+
+
+src_prepare() {
+ bzr_src_prepare
+}
+
+
+# Can't find out what the following line does (no Gentoo documentation on it?) and it seems to find the makefile and compile fine without it, so commenting it out.
+#MAKE_IN_SOURCE_BUILD=true
+
+
+# Actually, it looks like it is supposed to be CMAKE_IN_SOURCE_BUILD
+# http://devmanual.gentoo.org/eclass-reference/cmake-utils.eclass/index.html
+#CMAKE_IN_SOURCE_BUILD=true
+
+
+
+# Next section is inspired from...
+# https://bugs.launchpad.net/cairo-dock-plug-ins/+bug/922981
+# and
+# http://code.google.com/p/rion-overlay/source/browse/x11-misc/cairo-dock-plugins/cairo-dock-plugins-2.3.9999.ebuild?spec=svn71d4acbbb8c297b818ff886fb5dd434a6f54c377&r=71d4acbbb8c297b818ff886fb5dd434a6f54c377
+
+
+src_configure() {
+# MYCMAKEARGS="-DROOT_PREFIX=${D}" cmake-utils_src_configure
+ mycmakeargs="${mycmakeargs} -DROOT_PREFIX=${D} -DCMAKE_INSTALL_PREFIX=/usr"
+ cmake-utils_src_configure
+# econf
+}
+
+
+pkg_postinst() {
+ ewarn ""
+ ewarn ""
+ ewarn "THIS IS A LIVE EBUILD, SO IT MAY NOT RUN RIGHT!"
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ ewarn "Please report all bugs to write2david@gmail.com"
+ ewarn ""
+ ewarn ""
+}