summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Laitl <matej@laitl.cz>2011-06-11 16:50:30 +0200
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-11 17:14:45 +0200
commit20edc63aa23136627bcd35606d0c5d7a152edee0 (patch)
tree5f6bf84a31af872c9a53bf0223daec03112fa134
parent[sys-boot/grub] Rename efi cutting so it does not break qemu targets. Add loo... (diff)
downloadscarabeus-20edc63aa23136627bcd35606d0c5d7a152edee0.tar.gz
scarabeus-20edc63aa23136627bcd35606d0c5d7a152edee0.tar.bz2
scarabeus-20edc63aa23136627bcd35606d0c5d7a152edee0.zip
different solution for efi hack (rename efi flags back to efi-nn)
-rw-r--r--sys-boot/grub/Manifest4
-rw-r--r--sys-boot/grub/grub-1.99.ebuild18
-rw-r--r--sys-boot/grub/grub-9999.ebuild18
3 files changed, 20 insertions, 20 deletions
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index 75508d4..70cc111 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -1,5 +1,5 @@
AUX grub.default 1127 RMD160 a884e842cb203687cac4cac6551b0feed58d3b7a SHA1 5878147845b5d4b4aac34ce046ead60b93c3170c SHA256 32664f2e0bdd05cf9579f8e098aa0add76ef7bf7b37eb103c6d0f625204f44d3
DIST grub-1.99.tar.xz 2639224 RMD160 d59a47fa40b2be0d5ea5b2b00ff5538cfa147747 SHA1 a5ae9558f30ce7757a76aa130088b053a87e2fb6 SHA256 f308148d4c83c6f16a73b58a0cd39381656edb740929028cae7ad5f0d651021b
-EBUILD grub-1.99.ebuild 7683 RMD160 12631ba0d4d494bc0de901cbc11fb76f34938f29 SHA1 c2a90722db4cf03ed6334cc597f3504884814b4c SHA256 3bde7f19ec359b7ce33e50b1d7b4fd07f27e6bdcf576bb54cbb06fe3b6d9319b
-EBUILD grub-9999.ebuild 7684 RMD160 ad7613fb1cccf77d2a81a75840db737cf641a936 SHA1 c46926839bc99ede02aaa21709fcd702c7fefa08 SHA256 bf2c6a9db29e0e3a39ae345bafe0cb43dde0330348e4c8922dc9e10924d46139
+EBUILD grub-1.99.ebuild 7673 RMD160 896bfea26ed04644e1998ad97e0bd63080c005c6 SHA1 4977fd57f41655022130cfb257c46d6192b6306b SHA256 abbe58c09a20c05d702a186b7172a5924804eb44d602f474867966799276aee8
+EBUILD grub-9999.ebuild 7674 RMD160 906fc75149f13f3fc8b6f18f05e9f54ae0701a69 SHA1 101341a41a674a06942b518f7c88ba7db5c025ca SHA256 7603e93cf94b5dd73dc3a902e4556ee75dd594324cb92be4cf96695827a18a1d
MISC metadata.xml 264 RMD160 3cb995676f964b9637fbfc0027a81b9409802608 SHA1 c4d35e3a71c545cdf1aae525de803126bf54f596 SHA256 9bd1ce830cf1b821978ab90c81b2e369177a8d7c1bfe2dd2868419872c097f64
diff --git a/sys-boot/grub/grub-1.99.ebuild b/sys-boot/grub/grub-1.99.ebuild
index 1f19fd3..98835e3 100644
--- a/sys-boot/grub/grub-1.99.ebuild
+++ b/sys-boot/grub/grub-1.99.ebuild
@@ -26,7 +26,7 @@ SLOT="2"
[[ ${PV} != "9999" ]] && KEYWORDS="~amd64 ~x86 ~mips ~ppc ~ppc64"
IUSE="custom-cflags debug device-mapper nls static sdl truetype"
-GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips yeeloong"
+GRUB_PLATFORMS="coreboot efi-32 efi-64 emu ieee1275 multiboot pc qemu qemu-mips yeeloong"
# everywhere:
# emu
# mips only:
@@ -34,9 +34,9 @@ GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips
# amd64, x86, ppc, ppc64
# ieee1275
# amd64, x86
-# coreboot, multiboot, efi_32, pc, qemu
+# coreboot, multiboot, efi-32, pc, qemu
# amd64
-# efi_64
+# efi-64
for i in ${GRUB_PLATFORMS}; do
IUSE+=" grub_platforms_${i}"
done
@@ -132,19 +132,19 @@ grub_src_configure() {
# check if we have to specify the target (EFI)
# or just append correct --with-platform
if [[ -n ${platform} ]]; then
- if [[ ${platform/_*} == ${platform} ]]; then
- platform=" --with-platform=${platform}"
- else
+ if [[ ${platform} == efi* ]]; then
# EFI platform hack
- [[ ${platform/*_} == 32 ]] && target=i386
- [[ ${platform/*_} == 64 ]] && target=x86_64
+ [[ ${platform/*-} == 32 ]] && target=i386
+ [[ ${platform/*-} == 64 ]] && target=x86_64
# program-prefix is required empty because otherwise it is equal to
# target variable, which we do not want at all
platform="
- --with-platform=${platform/_*}
+ --with-platform=${platform/-*}
--target=${target}
--program-prefix=
"
+ else
+ platform=" --with-platform=${platform}"
fi
fi
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 7ae0b4e..f0bc2bf 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -26,7 +26,7 @@ SLOT="2"
[[ ${PV} != "9999" ]] && KEYWORDS="~amd64 ~x86 ~mips ~ppc ~ppc64"
IUSE="custom-cflags debug device-mapper nls static sdl truetype"
-GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips loongson"
+GRUB_PLATFORMS="coreboot efi-32 efi-64 emu ieee1275 multiboot pc qemu qemu-mips loongson"
# everywhere:
# emu
# mips only:
@@ -34,9 +34,9 @@ GRUB_PLATFORMS="coreboot efi_32 efi_64 emu ieee1275 multiboot pc qemu qemu-mips
# amd64, x86, ppc, ppc64
# ieee1275
# amd64, x86
-# coreboot, multiboot, efi_32, pc, qemu
+# coreboot, multiboot, efi-32, pc, qemu
# amd64
-# efi_64
+# efi-64
for i in ${GRUB_PLATFORMS}; do
IUSE+=" grub_platforms_${i}"
done
@@ -132,19 +132,19 @@ grub_src_configure() {
# check if we have to specify the target (EFI)
# or just append correct --with-platform
if [[ -n ${platform} ]]; then
- if [[ ${platform/_*} == ${platform} ]]; then
- platform=" --with-platform=${platform}"
- else
+ if [[ ${platform} == efi* ]]; then
# EFI platform hack
- [[ ${platform/*_} == 32 ]] && target=i386
- [[ ${platform/*_} == 64 ]] && target=x86_64
+ [[ ${platform/*-} == 32 ]] && target=i386
+ [[ ${platform/*-} == 64 ]] && target=x86_64
# program-prefix is required empty because otherwise it is equal to
# target variable, which we do not want at all
platform="
- --with-platform=${platform/_*}
+ --with-platform=${platform/-*}
--target=${target}
--program-prefix=
"
+ else
+ platform=" --with-platform=${platform}"
fi
fi