aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-06 03:25:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-06 03:25:25 +0100
commitc8e13f0ddf2812355c107dd82262138b5e35c91d (patch)
treeb31a2c0fdb868ee3a42e3d4c224047ed145ea2ad /www-client/seamonkey
parentwww-client/firefox, mail-client/thunderbird, eclass/mozconfig-v6.52 : (diff)
downloadmozilla-c8e13f0ddf2812355c107dd82262138b5e35c91d.tar.gz
mozilla-c8e13f0ddf2812355c107dd82262138b5e35c91d.tar.bz2
mozilla-c8e13f0ddf2812355c107dd82262138b5e35c91d.zip
seamonkey: Fix build with libevent-2.1
Diffstat (limited to 'www-client/seamonkey')
-rw-r--r--www-client/seamonkey/files/firefox-52-curve.patch34
-rw-r--r--www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch14
-rw-r--r--www-client/seamonkey/seamonkey-2.46-r1.ebuild6
3 files changed, 2 insertions, 52 deletions
diff --git a/www-client/seamonkey/files/firefox-52-curve.patch b/www-client/seamonkey/files/firefox-52-curve.patch
deleted file mode 100644
index 508d5805..00000000
--- a/www-client/seamonkey/files/firefox-52-curve.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-# HG changeset patch
-# User Franziskus Kiefer <franziskuskiefer@gmail.com>
-# Date 1469717280 -7200
-# Thu Jul 28 16:48:00 2016 +0200
-# Node ID 95aa61f1e3562e526bf88179d9d078fd90ad1bda
-# Parent d42aacfe34af25e2f5110e2ca3d24a210eabeb33
-Update keybits in H2, r=mt
-
-MozReview-Commit-ID: 35oWoDMqe1Y
-
-diff --git a/netwerk/protocol/http/Http2Session.cpp b/netwerk/protocol/http/Http2Session.cpp
---- a/netwerk/protocol/http/Http2Session.cpp
-+++ b/netwerk/protocol/http/Http2Session.cpp
-@@ -3544,18 +3544,18 @@ Http2Session::ConfirmTLSProfile()
- RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
- }
-
- uint32_t keybits = ssl->GetKEAKeyBits();
- if (kea == ssl_kea_dh && keybits < 2048) {
- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to DH %d < 2048\n",
- this, keybits));
- RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
-- } else if (kea == ssl_kea_ecdh && keybits < 256) { // 256 bits is "security level" of 128
-- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 256\n",
-+ } else if (kea == ssl_kea_ecdh && keybits < 224) { // see rfc7540 9.2.1.
-+ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 224\n",
- this, keybits));
- RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
- }
-
- int16_t macAlgorithm = ssl->GetMACAlgorithmUsed();
- LOG3(("Http2Session::ConfirmTLSProfile %p MAC Algortihm (aead==6) %d\n",
- this, macAlgorithm));
- if (macAlgorithm != nsISSLSocketControl::SSL_MAC_AEAD) {
diff --git a/www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch b/www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch
deleted file mode 100644
index 6928f84d..00000000
--- a/www-client/seamonkey/files/seamonkey-2.46-configure_regexp.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/604696
-https://bugzilla.mozilla.org/show_bug.cgi?id=1329252
-
---- seamonkey-2.46/mozilla/build/autoconf/icu.m4
-+++ seamonkey-2.46/mozilla/build/autoconf/icu.m4
-@@ -70,7 +70,7 @@
- fi
- fi
-
-- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
-+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
- if test x"$version" = x; then
- AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
- fi
diff --git a/www-client/seamonkey/seamonkey-2.46-r1.ebuild b/www-client/seamonkey/seamonkey-2.46-r1.ebuild
index 2876ebfd..7630d0e8 100644
--- a/www-client/seamonkey/seamonkey-2.46-r1.ebuild
+++ b/www-client/seamonkey/seamonkey-2.46-r1.ebuild
@@ -61,8 +61,8 @@ MOZCONFIG_OPTIONAL_WIFI=1
MOZCONFIG_OPTIONAL_JIT="enabled"
inherit check-reqs flag-o-matic toolchain-funcs eutils mozconfig-v6.49 multilib pax-utils fdo-mime autotools mozextension nsplugins mozlinguas-v2
-PATCHFF="firefox-49.0-patches-03"
-PATCH="${PN}-2.46-patches-01"
+PATCHFF="firefox-49.0-patches-04"
+PATCH="${PN}-2.46-patches-02"
EMVER="1.9.6.1"
DESCRIPTION="Seamonkey Web Browser"
@@ -135,13 +135,11 @@ src_unpack() {
src_prepare() {
# Apply our patches
eapply "${WORKDIR}"/seamonkey
- eapply "${FILESDIR}"/${PN}-2.46-configure_regexp.patch
# browser patches go here
pushd "${S}"/mozilla &>/dev/null || die
rm -f "${WORKDIR}"/firefox/2000-firefox_gentoo_install_dirs.patch
eapply "${WORKDIR}"/firefox
- eapply "${FILESDIR}"/firefox-52-curve.patch
popd &>/dev/null || die
# Shell scripts sometimes contain DOS line endings; bug 391889