aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-02-13 20:51:06 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-02-13 20:51:06 +0100
commitb7604272d3545f788e69055dca196cb304d7ea1d (patch)
treed2b2a3044ef3b92b76387d47994e78471b785759 /sci-chemistry
parentsci-chemistry/ccpn version bump to 2.0.6.1 (diff)
parentAdd patch for gcc 4.3 (diff)
downloadsci-b7604272d3545f788e69055dca196cb304d7ea1d.tar.gz
sci-b7604272d3545f788e69055dca196cb304d7ea1d.tar.bz2
sci-b7604272d3545f788e69055dca196cb304d7ea1d.zip
Merge branch 'master' of git+ssh://git@git.overlays.gentoo.org/proj/sci
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/icm/ChangeLog10
-rw-r--r--sci-chemistry/icm/Manifest15
-rw-r--r--sci-chemistry/icm/files/90icm3
-rw-r--r--sci-chemistry/icm/icm-3.6.1d.ebuild57
-rw-r--r--sci-chemistry/icm/metadata.xml9
-rw-r--r--sci-chemistry/wxmacmolplt/ChangeLog14
-rw-r--r--sci-chemistry/wxmacmolplt/Manifest16
-rw-r--r--sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-gcc43.patch9
-rw-r--r--sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-ming.patch11
-rw-r--r--sci-chemistry/wxmacmolplt/metadata.xml8
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild39
11 files changed, 191 insertions, 0 deletions
diff --git a/sci-chemistry/icm/ChangeLog b/sci-chemistry/icm/ChangeLog
new file mode 100644
index 000000000..fe61691db
--- /dev/null
+++ b/sci-chemistry/icm/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/icm
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*icm-3.6.1d (13 Feb 2009)
+
+ 13 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org> +files/90icm,
+ +metadata.xml, +icm-3.6.1d.ebuild:
+ Add ICM-pro initialy
+
diff --git a/sci-chemistry/icm/Manifest b/sci-chemistry/icm/Manifest
new file mode 100644
index 000000000..bf764cac1
--- /dev/null
+++ b/sci-chemistry/icm/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 90icm 84 RMD160 e994059f717008f62d35dcbe3a4dca5571e38b4c SHA1 019ae240f76734dae6fdcbd7f332e37ecdf89f11 SHA256 b08d5769a93a74350173395cc206426b9c373f32d2211852c83bc0d1d9554403
+DIST icm-3.6-1d.i386.rpm 103434638 RMD160 eb7c305e6355430fffb9f367bfbee6995d1915cf SHA1 e70ac43f056ceffd673af7386df2708d31dd9484 SHA256 832a7b31f18ed772c1320e143dac7a1d1f9ab080227a42a1dcb09ae355967855
+EBUILD icm-3.6.1d.ebuild 1234 RMD160 05c4158a87b68f0f77c300aaf618aa59d83447e8 SHA1 c3e8eaa6b92ae722f8e41105a583f02f38caa251 SHA256 e215e21100445afd796593e73bc3d5feda68bb47510893fb46a740baa393cfc1
+MISC ChangeLog 271 RMD160 33e76a009df2ea73d33de7c223a371c780a03dfd SHA1 da5a8b7b6464d7fddc85dd782989af66bb62647f SHA256 015bf23408fbe050b3a3c1baba3f7e78b6a1d55ac5862cf8dc4a61214e10acf2
+MISC metadata.xml 257 RMD160 a36571e1f0e18fb7a18b73d5fb37d9bd0861fb49 SHA1 a0ddeb1a8d81d113bfc8a4cf1cd0717f847fd758 SHA256 344d9ca6a57b35b97682e144d205204c0b7da04a53ea67c7b3c89b8c8c8b5e5f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkmVT+MACgkQ5BmOA85PVLiorgCfZGLfYHyEsKFyXkXF4eYeVRAz
+TzYAn2B5rnXBEh40xgEZ7bUPx4YjJSRP
+=Jlv0
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/icm/files/90icm b/sci-chemistry/icm/files/90icm
new file mode 100644
index 000000000..ce8966c40
--- /dev/null
+++ b/sci-chemistry/icm/files/90icm
@@ -0,0 +1,3 @@
+ICMHOME=/opt/icm
+LM_LICENSE_FILE=/opt/icm/licenses/license.dat
+MANPATH=/opt/icm/man
diff --git a/sci-chemistry/icm/icm-3.6.1d.ebuild b/sci-chemistry/icm/icm-3.6.1d.ebuild
new file mode 100644
index 000000000..68b14b2e5
--- /dev/null
+++ b/sci-chemistry/icm/icm-3.6.1d.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit rpm eutils versionator
+
+MY_PV=$(replace_version_separator 2 '-' )
+MY_P="$PN-${MY_PV}"
+DESCRIPTION="MolSoft LCC ICM Pro"
+SRC_URI="${MY_P}.i386.rpm"
+HOMEPAGE="http://molsoft.com"
+LICENSE="MolSoft"
+
+SLOT=0
+DEPEND="x11-drivers/nvidia-drivers"
+RDEPEND=">=sys-libs/glibc-2.2.5
+ virtual/libstdc++"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch"
+S="${WORKDIR}/usr/${MY_P}"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from "
+ einfo "${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}" || die
+}
+
+src_install () {
+ instdir=/opt/icm
+ dodir "${instdir}"
+ dodir "${instdir}/licenses"
+ cp -pPR * "${D}/${instdir}"
+ doenvd "${FILESDIR}/90icm" || die
+ exeinto ${instdir}
+ doexe "${S}/icm" || die
+ doexe "${S}/lmhostid" || die
+ doexe "${S}/txdoc" || die
+ dosym "${instdir}/icm" /opt/bin/icm || die
+ dosym "${instdir}/txdoc" /opt/bin/txdoc || die
+ dosym "${instdir}/lmhostid" /opt/bin/lmhostid || die
+}
+
+pkg_postinst () {
+ einfo
+ einfo "Documentation can be found in ${instdir}/man/"
+ einfo
+ einfo "You will need to place your license in ${instdir}/licenses/"
+ einfo
+
+}
+
diff --git a/sci-chemistry/icm/metadata.xml b/sci-chemistry/icm/metadata.xml
new file mode 100644
index 000000000..3cfdd8f68
--- /dev/null
+++ b/sci-chemistry/icm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/wxmacmolplt/ChangeLog b/sci-chemistry/wxmacmolplt/ChangeLog
new file mode 100644
index 000000000..80932620b
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sci-chemistry/wxmacmolplt
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 13 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/wxmacmolplt-7.2.1-gcc43.patch, wxmacmolplt-7.2.1.ebuild:
+ Add patch for gcc 4.3
+
+*wxmacmolplt-7.2.1 (13 Feb 2009)
+
+ 13 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/wxmacmolplt-7.2.1-ming.patch, +wxmacmolplt-7.2.1.ebuild:
+ Add wxmacmolplt initialy bug #197131
+
diff --git a/sci-chemistry/wxmacmolplt/Manifest b/sci-chemistry/wxmacmolplt/Manifest
new file mode 100644
index 000000000..85643a3be
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX wxmacmolplt-7.2.1-gcc43.patch 286 RMD160 89024e9ab6a06ab66f9248c8c9c9f88f8678585c SHA1 fa396b662f58c6ccc784b38f1f0909b46de549b1 SHA256 f3faa0616d02be3590d52dc95fdff55a9343dfde7df74c785689bdcafd51880c
+AUX wxmacmolplt-7.2.1-ming.patch 402 RMD160 44e8644cf7f28549fd24432979e1982753f31e92 SHA1 bb838d234cd3e6af66b9acd43b3a46b30450bb65 SHA256 159d6ade9ec84f1247d92f4cfd8f7a28d73651bf8d0e42ff2d181b3a7af6f999
+DIST wxmacmolplt-7.2.1.tar.gz 1617541 RMD160 7da381f33578d2b578efa937691b4ca8b461eb8b SHA1 45d3f43f33bf334ac6b6d7b187c271d8fd6ef32b SHA256 1e079a05da1738118164488722246377744ad3a6d1def5fb5965eed803bf69d4
+EBUILD wxmacmolplt-7.2.1.ebuild 851 RMD160 4cc43a64a1ef5199bc402e886adf7e6895be0782 SHA1 bebf6fafd66b6d21d2201a19a3059d1783a8c365 SHA256 ec2c522f2e05f7521d3a81c3d0bae91acee12517395f060fd0bc0ead2b002d10
+MISC ChangeLog 459 RMD160 91258f33a5b38476a4b2eff3cb63b1128dfeb653 SHA1 bc3643768d4de651693d1a47a1a5eb388001fe2e SHA256 83c12ce78e776be485bb61df917dc2b3b79b45930d9c4de7f62d49204fb666e7
+MISC metadata.xml 245 RMD160 18596976a5c01cb139ec864df9c3e5af31bb7e84 SHA1 11a9e38cb22a455bfa7164418b209da0d1abedf6 SHA256 643385b3a789b424bcc6dc46fe5dc1607071820f9fd35fe91de2e7984f97cdfd
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkmVVdQACgkQ5BmOA85PVLjG2wCcCEK+XqsA1786CHMHQwT/qDpM
+AAQAoJ2DOgtFw1UuGfPkIGAqzyY0x1z2
+=tdbQ
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-gcc43.patch b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-gcc43.patch
new file mode 100644
index 000000000..c98204f9b
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-gcc43.patch
@@ -0,0 +1,9 @@
+--- wxmacmolplt-7.2.1/src/Geometries.cpp.orig 2009-02-13 14:06:06.000000000 +0300
++++ wxmacmolplt-7.2.1/src/Geometries.cpp 2009-02-13 14:06:54.000000000 +0300
+@@ -1,5 +1,6 @@
+ #include <iomanip>
+ #include <iostream>
++#include <stdlib.h>
+
+ #include "Geometries.h"
+ #include "Globals.h"
diff --git a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-ming.patch b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-ming.patch
new file mode 100644
index 000000000..e633f5288
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.2.1-ming.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-05-13 19:27:34.000000000 +0300
++++ configure.ac 2008-11-14 21:41:44.000000000 +0200
+@@ -39,7 +39,7 @@
+ [AC_SUBST([LIBMING], ["-lming"]) AC_DEFINE([HAVE_LIBMING])],
+ [if test "x$with_ming" != xyes; then
+ AC_MSG_FAILURE([--with-ming was given, but test for ming failed])
+- fi], -lpng)])
++ fi], -lpng -lgif)])
+
+ WXCONFIG=wx-config
+ AC_ARG_WITH(wx-config,
diff --git a/sci-chemistry/wxmacmolplt/metadata.xml b/sci-chemistry/wxmacmolplt/metadata.xml
new file mode 100644
index 000000000..1aea1ef06
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<use>
+ <flag name='ming'>Add support for flash movie generation</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild
new file mode 100644
index 000000000..78e09e16a
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/~brett/MacMolPlt/"
+
+SRC_URI="http://www.scl.ameslab.gov/~brett/MacMolPlt/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="ming"
+
+RDEPEND="x11-libs/wxGTK
+ ming? ( media-libs/ming )"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ming.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
+src_compile() {
+ econf $(use_with ming) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN}.png Education
+}