summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-11 10:37:48 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-11 10:38:09 -0400
commitf44a1236fac5a45cb21d26e5e31583cc5bdd1ed8 (patch)
tree4e593e5cff8d467f44a6a39f77a06774f709f880 /dev-lang/php
parentdev-python/pythonmagick: Remove v0.9.11 relying on unsecure and outdated rele... (diff)
downloadgentoo-f44a1236fac5a45cb21d26e5e31583cc5bdd1ed8.tar.gz
gentoo-f44a1236fac5a45cb21d26e5e31583cc5bdd1ed8.tar.bz2
gentoo-f44a1236fac5a45cb21d26e5e31583cc5bdd1ed8.zip
dev-lang/php: new revisions fixing opcache installation location logic.
We install the opcache extension with a call to dolib.so, which requires an earlier call to "into" to set its installation location. If the user enables any SAPIs other than apache2, that happens incidentally. However, if only the apache2 SAPI is enabled, the installation location is never set, ultimately causing the extension to fail to load. This is fixed by adding a call to "into" directly before the dolib.so call. Two calls to use_if_iuse were also replaced with the simpler "use". Gentoo-Bug: 550676 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-5.6.23-r2.ebuild (renamed from dev-lang/php/php-5.6.23-r1.ebuild)5
-rw-r--r--dev-lang/php/php-7.0.8-r1.ebuild (renamed from dev-lang/php/php-7.0.8.ebuild)5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/php/php-5.6.23-r1.ebuild b/dev-lang/php/php-5.6.23-r2.ebuild
index 0696638dbbe6..071afe4e72df 100644
--- a/dev-lang/php/php-5.6.23-r1.ebuild
+++ b/dev-lang/php/php-5.6.23-r2.ebuild
@@ -255,7 +255,7 @@ php_install_ini() {
dodir "${PHP_EXT_INI_DIR#${EPREFIX}}"
dodir "${PHP_EXT_INI_DIR_ACTIVE#${EPREFIX}}"
- if use_if_iuse opcache; then
+ if use opcache; then
elog "Adding opcache to $PHP_EXT_INI_DIR"
echo "zend_extension=${PHP_DESTDIR}/$(get_libdir)/opcache.so" >> \
"${D}/${PHP_EXT_INI_DIR}"/opcache.ini
@@ -666,7 +666,8 @@ src_install() {
done
# Installing opcache module
- if use_if_iuse opcache ; then
+ if use opcache ; then
+ into "${PHP_DESTDIR#${EPREFIX}}"
dolib.so "modules/opcache$(get_libname)"
fi
diff --git a/dev-lang/php/php-7.0.8.ebuild b/dev-lang/php/php-7.0.8-r1.ebuild
index 5925bb3a4da4..9bd15572e425 100644
--- a/dev-lang/php/php-7.0.8.ebuild
+++ b/dev-lang/php/php-7.0.8-r1.ebuild
@@ -246,7 +246,7 @@ php_install_ini() {
dodir "${PHP_EXT_INI_DIR#${EPREFIX}}"
dodir "${PHP_EXT_INI_DIR_ACTIVE#${EPREFIX}}"
- if use_if_iuse opcache; then
+ if use opcache; then
elog "Adding opcache to $PHP_EXT_INI_DIR"
echo "zend_extension=${PHP_DESTDIR}/$(get_libdir)/opcache.so" >> \
"${D}/${PHP_EXT_INI_DIR}"/opcache.ini
@@ -660,7 +660,8 @@ src_install() {
done
# Installing opcache module
- if use_if_iuse opcache ; then
+ if use opcache ; then
+ into "${PHP_DESTDIR#${EPREFIX}}"
dolib.so "modules/opcache$(get_libname)"
fi