summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-03-27 18:54:46 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-03-28 12:07:09 -0700
commita77a5e53e7edf95d22f91756354e10a38282bd59 (patch)
tree6eac92aa9aa0eb9b141b9d1fb05ef875017d9b0c /dev-python/xdis
parentdev-python/constantly: New pkg, split out from twisted new dep of twisted (diff)
downloadgentoo-a77a5e53e7edf95d22f91756354e10a38282bd59.tar.gz
gentoo-a77a5e53e7edf95d22f91756354e10a38282bd59.tar.bz2
gentoo-a77a5e53e7edf95d22f91756354e10a38282bd59.zip
dev-python/xdis: Version bump, remove older versions not compatible with python-3.5.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Diffstat (limited to 'dev-python/xdis')
-rw-r--r--dev-python/xdis/Manifest2
-rw-r--r--dev-python/xdis/files/xdis-test_magic_bytes_error.patch24
-rw-r--r--dev-python/xdis/xdis-2.3.1.ebuild45
-rw-r--r--dev-python/xdis/xdis-3.2.3.ebuild45
-rw-r--r--dev-python/xdis/xdis-3.2.4.ebuild6
5 files changed, 28 insertions, 94 deletions
diff --git a/dev-python/xdis/Manifest b/dev-python/xdis/Manifest
index d32e9cf23632..6aea180d09e9 100644
--- a/dev-python/xdis/Manifest
+++ b/dev-python/xdis/Manifest
@@ -1,3 +1 @@
-DIST xdis-2.3.1.tar.gz 69207 SHA256 9b28426a5b476b6740b83063604de7ef4af8b721a5da5894145fbae8921d25ae SHA512 5015914a13296d04e71050c2e916fd5770bfe8bba1f92bf3c64bca06365ea7547cbb216d7cfca19fdcef60af3943fa4ba4e7c27895b1da9c6240daf990051927 WHIRLPOOL c30ae717289c73069efbdb70cdd6388bb009e945c967de53b159aa2f8a606cdca8e28b265b4da56b7f77ab01b8a415b8d8d8b7e1b972370121ab86b18d8921e7
-DIST xdis-3.2.3.tar.gz 126710 SHA256 2e11b7dfafc02ce28da15f1d1bed327384ec34333d4a03e76cee8c1840897a5e SHA512 ce4e2ad09c1d13b2ab35b931ceedb8d08ec2f81dc2a34f50f854e6a4aca5efe857b56d6c2f1dbd73ae12d4ec9e2b0cc8e20c08873e87e4b0ca80fac229cebe06 WHIRLPOOL 1f553c3c57df5419b42ef6c94f7b78b5cbac14615d2d4066234420acd925b83df851332485a16ec8cace9ee5182b21b5bc1fc2fad7199ff4d6f17ce7de189cdb
DIST xdis-3.2.4.tar.gz 127507 SHA256 b311253b97a321ab45625089a729ccbf8bcb1319a8c4c0167b719f81c081543c SHA512 6c9274e10f2a41ab4a173c8ae4462374fc7ab444a589ab572172550d0f5284906f7d9c9cf4a640f163f6012d17f40bc5e1c36e5963f8b6106a9c37e420027a97 WHIRLPOOL 5a0910f04e3d9ec70129d5d3b659fe06034e7a6298692d2a776f2616a8b895a539efa7f96972b2adc6986c2475e697552ea071d33bdd22c60bb1e0fec1950dd4
diff --git a/dev-python/xdis/files/xdis-test_magic_bytes_error.patch b/dev-python/xdis/files/xdis-test_magic_bytes_error.patch
new file mode 100644
index 000000000000..560f58b7611e
--- /dev/null
+++ b/dev-python/xdis/files/xdis-test_magic_bytes_error.patch
@@ -0,0 +1,24 @@
+From 8aa4a91d664380395f08b0ccd4aa944d53a21e55 Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Mon, 27 Mar 2017 18:13:00 -0700
+Subject: [PATCH] test_unit/test_magic.py: Add python-3.5.3 magic
+
+---
+ xdis/magics.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xdis/magics.py b/xdis/magics.py
+index 6a58040..571f0ea 100755
+--- a/xdis/magics.py
++++ b/xdis/magics.py
+@@ -103,6 +103,7 @@ versions = {
+ int2magic(3300): '3.4a4+', # more changes to __qualname__ computation
+ int2magic(3310): '3.4rc2', # alter __qualname__ computation
+ int2magic(3350): '3.5', # 3.5.0, 3.5.1, 3.5.2
++ int2magic(3351): '3.5.3', # 3.5.3
+ int2magic(3361): '3.6.0a1', # 3.6.0a1
+ int2magic(3370): '3.6.0a1+1', # 3.6.0a?
+ int2magic(3370): '3.6.0a1+2', #
+--
+2.12.1
+
diff --git a/dev-python/xdis/xdis-2.3.1.ebuild b/dev-python/xdis/xdis-2.3.1.ebuild
deleted file mode 100644
index 73346d881de9..000000000000
--- a/dev-python/xdis/xdis-2.3.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
-
-inherit distutils-r1
-
-DESCRIPTION="Python cross-version byte-code disassembler and marshal routines"
-HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.python.org/pypi/xdis"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/nose-1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Remove the 3.3 specific code from being run
- rm -R "test_unit/3.3" || die
- # Remove an unconditional test only dep
- sed \
- -e "s/setup_requires/tests_require/" \
- -i setup.py
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \
- py.test -v || die "Tests failed under ${EPYTHON}"
- cd test
- PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
- ${EPYTHON} test_pyenvlib.py --verify --simple --compile || die \
- "Tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/xdis/xdis-3.2.3.ebuild b/dev-python/xdis/xdis-3.2.3.ebuild
deleted file mode 100644
index 535c7010aff4..000000000000
--- a/dev-python/xdis/xdis-3.2.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
-
-inherit distutils-r1
-
-DESCRIPTION="Python cross-version byte-code disassembler and marshal routines"
-HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.python.org/pypi/xdis"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/nose-1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Fix an unconditional test only dep
- sed \
- -e "s/setup_requires/tests_require/" \
- -i setup.py
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Need to rm any pyc files to prevent test failures.
- rm -R "${S}"/test/__pycache__
- PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \
- py.test -v || die "Tests failed under ${EPYTHON}"
- cd test
- PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
- ${EPYTHON} test_pyenvlib.py --verify --simple --compile || die \
- "Tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/xdis/xdis-3.2.4.ebuild b/dev-python/xdis/xdis-3.2.4.ebuild
index 4b6a2f742081..f1ec7b951a7f 100644
--- a/dev-python/xdis/xdis-3.2.4.ebuild
+++ b/dev-python/xdis/xdis-3.2.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
inherit distutils-r1
@@ -25,6 +25,8 @@ DEPEND="
)
"
+PATCHES=( "${FILESDIR}/xdis-test_magic_bytes_error.patch" )
+
python_prepare_all() {
# Fix an unconditional test only dep
sed \