summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-12-07 18:37:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-11 09:58:09 +0200
commitdc8edaa92db78c8d861d15f2ee252ed1eb88141f (patch)
treeb36606fd3ba429bf00c4ba7d4e7f581833e82bb2 /sys-auth/seatd/seatd-0.4.0-r1.ebuild
parentdev-libs/libusb: Removed old (diff)
downloadgentoo-dc8edaa92db78c8d861d15f2ee252ed1eb88141f.tar.gz
gentoo-dc8edaa92db78c8d861d15f2ee252ed1eb88141f.tar.bz2
gentoo-dc8edaa92db78c8d861d15f2ee252ed1eb88141f.zip
sys-auth/seatd: Install systemd service file
Closes: https://bugs.gentoo.org/754657 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/18555 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-auth/seatd/seatd-0.4.0-r1.ebuild')
-rw-r--r--sys-auth/seatd/seatd-0.4.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/seatd/seatd-0.4.0-r1.ebuild b/sys-auth/seatd/seatd-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..ab311a6c5986
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.4.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="elogind systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dwerror=false
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -Dlogind=enabled )
+ else
+ emesonargs+=( -Dlogind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
+}