summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:33 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:41 +0100
commit306d02dba5fd17bf291bcf83acde372f3fcdd25d (patch)
tree18636d6201cff296e9c65bd2f400b7ad524c1d34
parentdev-libs/libvoikko: bump to 4.3 (diff)
downloadgentoo-306d02dba5fd17bf291bcf83acde372f3fcdd25d.tar.gz
gentoo-306d02dba5fd17bf291bcf83acde372f3fcdd25d.tar.bz2
gentoo-306d02dba5fd17bf291bcf83acde372f3fcdd25d.zip
dev-ml/llvm-ocaml: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild9
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild11
2 files changed, 15 insertions, 5 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
index b0d581bd9ff5..664c0aa44847 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
@@ -13,8 +13,8 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm
# Keep in sync with sys-devel/llvm
ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC AVR )
@@ -53,6 +53,11 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' llvm
+}
+
src_prepare() {
# Python is needed to run tests using lit
python_setup
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild
index ea47038cb443..d47587faed9b 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild
@@ -13,9 +13,9 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -52,6 +52,11 @@ pkg_setup() {
python-any-r1_pkg_setup
}
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' llvm
+}
+
src_prepare() {
# Python is needed to run tests using lit
python_setup