summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-31 11:05:29 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 22:56:06 +0100
commit5afeef3f4c40b4e2e72970c89a9e6ca34980428e (patch)
tree42c264e8b9cdc942395d8f564db525c1435cf10c
parentdev-lang/jimtcl: Stop using awful multijob_* logic (diff)
downloadgentoo-5afeef3f4c40b4e2e72970c89a9e6ca34980428e.tar.gz
gentoo-5afeef3f4c40b4e2e72970c89a9e6ca34980428e.tar.bz2
gentoo-5afeef3f4c40b4e2e72970c89a9e6ca34980428e.zip
dev-lang/jimtcl: Add missing ||die
-rw-r--r--dev-lang/jimtcl/jimtcl-0.76.ebuild8
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/jimtcl/jimtcl-0.76.ebuild b/dev-lang/jimtcl/jimtcl-0.76.ebuild
index 166bf52e88b0..0c0461946919 100644
--- a/dev-lang/jimtcl/jimtcl-0.76.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.76.ebuild
@@ -30,7 +30,7 @@ src_unpack() {
git-2_src_unpack
else
default
- cd "${WORKDIR}"/msteveb-jimtcl-*
+ cd "${WORKDIR}"/msteveb-jimtcl-* || die
S=${PWD}
fi
}
@@ -43,8 +43,8 @@ src_configure() {
CCACHE=None econf --with-jim-shared
if use static-libs ; then
# The build does not support doing both simultaneously.
- mkdir static-libs
- cd static-libs
+ mkdir static-libs || die
+ cd static-libs || die
CCACHE=None ECONF_SOURCE=${S} econf
fi
}
@@ -59,7 +59,7 @@ src_compile() {
src_install() {
dobin jimsh
use static-libs && dolib.a static-libs/libjim.a
- ln -sf libjim.so.* libjim.so
+ ln -sf libjim.so.* libjim.so || die
dolib.so libjim.so*
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index c3f079c046f3..64b38756f800 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -30,7 +30,7 @@ src_unpack() {
git-2_src_unpack
else
default
- cd "${WORKDIR}"/msteveb-jimtcl-*
+ cd "${WORKDIR}"/msteveb-jimtcl-* || die
S=${PWD}
fi
}
@@ -43,8 +43,8 @@ src_configure() {
CCACHE=None econf --with-jim-shared
if use static-libs ; then
# The build does not support doing both simultaneously.
- mkdir static-libs
- cd static-libs
+ mkdir static-libs || die
+ cd static-libs || die
CCACHE=None ECONF_SOURCE=${S} econf
fi
}
@@ -59,7 +59,7 @@ src_compile() {
src_install() {
dobin jimsh
use static-libs && dolib.a static-libs/libjim.a
- ln -sf libjim.so.* libjim.so
+ ln -sf libjim.so.* libjim.so || die
dolib.so libjim.so*
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \