summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:33 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:16:07 +0100
commit635494d3788266cc16df11d7512a27bedac1db22 (patch)
tree1a45a9f20e270becc1054049f4d063d7ae8c863d
parentx11-plugins/gkrellfire: Eclass update (diff)
downloadgentoo-635494d3788266cc16df11d7512a27bedac1db22.tar.gz
gentoo-635494d3788266cc16df11d7512a27bedac1db22.tar.bz2
gentoo-635494d3788266cc16df11d7512a27bedac1db22.zip
x11-plugins/gkrellm-volume: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
index db88433d0fe0..208a9d80056f 100644
--- a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
+++ b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="A mixer control plugin for gkrellm"
@@ -13,22 +14,20 @@ SLOT="2"
KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
IUSE="alsa"
-DEPEND="alsa? ( media-libs/alsa-lib )"
-RDEPEND="${DEPEND}
- app-admin/gkrellm[X]
-"
-
-S="${WORKDIR}/${PN}"
-
-PLUGIN_SO="volume.so"
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${PN}
PATCHES=(
"${FILESDIR}/${P}-reenable.patch"
"${FILESDIR}/${P}-makefile.patch"
)
+PLUGIN_SO=( volume$(get_modname) )
+
src_compile() {
- local myconf=""
- use alsa && myconf="${myconf} enable_alsa=1"
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" "${myconf}"
+ use alsa && local myconf="enable_alsa=1"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}
}