summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-29 10:25:40 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-29 10:25:55 +0100
commit97cd40a0e43816fb6a6af0e5bc55769f6d459145 (patch)
treec29dcf280313265e8e803dd4d4d011c960f71407
parentsci-libs/clapack: Restrict tests (diff)
downloadgentoo-97cd40a0e43816fb6a6af0e5bc55769f6d459145.tar.gz
gentoo-97cd40a0e43816fb6a6af0e5bc55769f6d459145.tar.bz2
gentoo-97cd40a0e43816fb6a6af0e5bc55769f6d459145.zip
sci-libs/clapack: Remove 3.2.1 (r7)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r7.ebuild41
-rw-r--r--sci-libs/clapack/files/clapack-3.2.1-findblas.patch49
2 files changed, 0 insertions, 90 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r7.ebuild b/sci-libs/clapack/clapack-3.2.1-r7.ebuild
deleted file mode 100644
index 4004c079c2f7..000000000000
--- a/sci-libs/clapack/clapack-3.2.1-r7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit flag-o-matic cmake-utils
-
-DESCRIPTION="f2c'ed version of LAPACK"
-HOMEPAGE="http://www.netlib.org/clapack/"
-SRC_URI="http://www.netlib.org/${PN}/${P}-CMAKE.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-libs/libf2c-20090407-r1
- virtual/blas"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${P}-CMAKE
-
-PATCHES=(
- "${FILESDIR}/${P}-fix_include_file.patch"
- "${FILESDIR}/${P}-noblasf2c.patch"
- "${FILESDIR}/${P}-hang.patch"
- "${FILESDIR}/${P}-findblas-r7.patch"
-)
-
-# bug 433806
-RESTRICT="test"
-
-src_configure() {
- filter-flags -ftree-vectorize
- # causes an internal compiler error with gcc-4.6.2
-
- local mycmakeargs=( $(cmake-utils_use_enable test TESTS) )
- cmake-utils_src_configure
-}
diff --git a/sci-libs/clapack/files/clapack-3.2.1-findblas.patch b/sci-libs/clapack/files/clapack-3.2.1-findblas.patch
deleted file mode 100644
index e2744f8de567..000000000000
--- a/sci-libs/clapack/files/clapack-3.2.1-findblas.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -ruN clapack-3.2.1-CMAKE.orig/CMakeLists.txt clapack-3.2.1-CMAKE/CMakeLists.txt
---- clapack-3.2.1-CMAKE.orig/CMakeLists.txt 2011-06-17 23:01:05.275747599 +0200
-+++ clapack-3.2.1-CMAKE/CMakeLists.txt 2011-06-17 23:07:49.128747755 +0200
-@@ -30,6 +30,28 @@
-
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
-
-+if(BLAS_LIBRARIES)
-+ include(CheckFortranFunctionExists)
-+ set(CMAKE_REQUIRED_LIBRARIES ${BLAS_LIBRARIES})
-+ CHECK_FORTRAN_FUNCTION_EXISTS("dgemm" BLAS_FOUND)
-+ unset( CMAKE_REQUIRED_LIBRARIES )
-+ if(BLAS_FOUND)
-+ message(STATUS "--> BLAS supplied by user is WORKING, will use ${BLAS_LIBRARIES}.")
-+ else(BLAS_FOUND)
-+ message(ERROR "--> BLAS supplied by user is not WORKING, CANNOT USE ${BLAS_LIBRARIES}.")
-+ message(ERROR "--> Will use REFERENCE BLAS (by default)")
-+ message(ERROR "--> Or Correct your BLAS_LIBRARIES entry ")
-+ message(ERROR "--> Or Consider checking USE_OPTIMIZED_BLAS")
-+ endif(BLAS_FOUND)
-+else(BLAS_LIBRARIES)
-+ # User did not provide a BLAS Library
-+ find_package( BLAS )
-+endif (BLAS_LIBRARIES)
-+
-+if(NOT BLAS_FOUND)
-+ message(FATAL_ERROR "--> BLAS libraries needed but not found.")
-+endif(NOT BLAS_FOUND)
-+
- add_subdirectory(SRC)
-
- if(ENABLE_TESTS)
-@@ -44,4 +66,3 @@
- ${CLAPACK_BINARY_DIR}/clapack-config-version.cmake @ONLY)
- configure_file(${CLAPACK_SOURCE_DIR}/clapack-config.cmake.in
- ${CLAPACK_BINARY_DIR}/clapack-config.cmake @ONLY)
--
-diff -ruN clapack-3.2.1-CMAKE.orig/SRC/CMakeLists.txt clapack-3.2.1-CMAKE/SRC/CMakeLists.txt
---- clapack-3.2.1-CMAKE.orig/SRC/CMakeLists.txt 2011-06-17 23:01:05.276747599 +0200
-+++ clapack-3.2.1-CMAKE/SRC/CMakeLists.txt 2011-06-17 23:08:43.761747789 +0200
-@@ -377,7 +377,7 @@
- endif()
-
- add_library(clapack SHARED ${ALLOBJ} ${ALLXOBJ})
--target_link_libraries(clapack blas f2c m)
-+target_link_libraries(clapack ${BLAS_LIBRARIES} f2c m)
- set_target_properties(clapack PROPERTIES SOVERSION "${CLAPACK_VERSION}")
-
- install(