summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-24 20:09:52 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:21:31 +0200
commitcf5fcb29eee560e862a2597d06f419210eda0179 (patch)
tree4a19100b1cfeffa5fe9ce4821acad69e9343e10d
parentx11-plugins/wmsystray: EAPI7, improve ebuild (diff)
downloadgentoo-cf5fcb29eee560e862a2597d06f419210eda0179.tar.gz
gentoo-cf5fcb29eee560e862a2597d06f419210eda0179.tar.bz2
gentoo-cf5fcb29eee560e862a2597d06f419210eda0179.zip
x11-plugins/wmtime: EAPI7, improve ebuild
-rw-r--r--x11-plugins/wmtime/wmtime-1.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmtime/wmtime-1.4-r1.ebuild b/x11-plugins/wmtime/wmtime-1.4-r1.ebuild
new file mode 100644
index 000000000000..4ea44b15579c
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="https://www.dockapps.net/wmtime"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( BUGS CHANGES HINTS README TODO )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ einstalldocs
+}