summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-07-13 15:23:10 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-07-13 15:23:10 -0400
commitd8c0ed452886ae274c3e2a8462059fc29ee8922f (patch)
treeaf941f6d577dd3b5b02390f568e5731860508156
parentnet-analyzer/nagircbot: add libressl support (diff)
downloadgentoo-d8c0ed452886ae274c3e2a8462059fc29ee8922f.tar.gz
gentoo-d8c0ed452886ae274c3e2a8462059fc29ee8922f.tar.bz2
gentoo-d8c0ed452886ae274c3e2a8462059fc29ee8922f.zip
net-analyzer/nessus-client: add libressl support and bump to EAPI=5
Package-Manager: portage-2.2.28
-rw-r--r--net-analyzer/nessus-client/nessus-client-1.0.2-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/nessus-client/nessus-client-1.0.2-r2.ebuild b/net-analyzer/nessus-client/nessus-client-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..c9d631594407
--- /dev/null
+++ b/net-analyzer/nessus-client/nessus-client-1.0.2-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+MY_PN=NessusClient
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A client for the Nessus vulnerability scanner"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz
+ mirror://gentoo/nessus-client.png.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl doc"
+
+RDEPEND="!net-analyzer/nessus-core
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ >=x11-libs/gtk+-2.8.8:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/htmldoc )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ sed -i \
+ -e "/NESSUS_DOCDIR/s|/doc/NessusClient|/doc/${PF}|g" \
+ nessus.tmpl.in || die
+}
+
+src_configure() {
+ tc-export CC
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES README_SSL VERSION
+
+ doicon "${WORKDIR}"/${PN}.png
+ make_desktop_entry NessusClient "Nessus Client" nessus-client "Network"
+}
+
+pkg_postinst() {
+ if ! use doc; then
+ elog "If you do not have documentation installed, nessus-client"
+ elog "will complain. To install documentation, please emerge with"
+ elog "the doc useflag set. Beware that it will emerge app-text/htmldoc,"
+ elog "a big package."
+ fi
+}