summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 22:41:29 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:32:50 +0100
commit3deb978bc9d01023b1acddc300c71ab09a6a35bb (patch)
treec137fdf0cfdb4b49ada28fc18e8e49e9268682ed /app-accessibility/sphinx2/sphinx2-0.6.ebuild
parentapp-accessibility/festival-hts: Port to EAPI 6 (diff)
downloadgentoo-3deb978bc9d01023b1acddc300c71ab09a6a35bb.tar.gz
gentoo-3deb978bc9d01023b1acddc300c71ab09a6a35bb.tar.bz2
gentoo-3deb978bc9d01023b1acddc300c71ab09a6a35bb.zip
app-accessibility/sphinx2: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-accessibility/sphinx2/sphinx2-0.6.ebuild')
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6.ebuild29
1 files changed, 20 insertions, 9 deletions
diff --git a/app-accessibility/sphinx2/sphinx2-0.6.ebuild b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
index d2fda0b62aef..0ca32c0a2170 100644
--- a/app-accessibility/sphinx2/sphinx2-0.6.ebuild
+++ b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit autotools eutils
+inherit autotools
MY_P=${P/_/}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="CMU Speech Recognition-engine"
HOMEPAGE="http://fife.speech.cs.cmu.edu/sphinx/"
@@ -15,15 +14,27 @@ SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+IUSE="static-libs"
+
+S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-as-needed.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old
- dohtml doc/phoneset_s2.html doc/sphinx2.html
+ HTML_DOCS=( doc/{phoneset_s2,sphinx2}.html )
+ default
+ dodoc doc/{README.{bin,lib},SCHMM_format,filler.dict,phoneset{,-old}}
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
}