summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-12-16 13:03:58 +0100
committerUlrich Müller <ulm@gentoo.org>2020-12-16 13:09:12 +0100
commit1021d268b8b73b06b4409115af18655ea42dd7ff (patch)
tree873e4df4cff213e7573f816eca593a6b4b6edd33 /app-admin/eselect/eselect-1.4.17.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {5.4.84,5.9.15} - remov... (diff)
downloadgentoo-1021d268b8b73b06b4409115af18655ea42dd7ff.tar.gz
gentoo-1021d268b8b73b06b4409115af18655ea42dd7ff.tar.bz2
gentoo-1021d268b8b73b06b4409115af18655ea42dd7ff.zip
app-admin/eselect: Version bump to 1.4.17.
Closes: https://bugs.gentoo.org/718920 Closes: https://bugs.gentoo.org/760081 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-admin/eselect/eselect-1.4.17.ebuild')
-rw-r--r--app-admin/eselect/eselect-1.4.17.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/eselect/eselect-1.4.17.ebuild b/app-admin/eselect/eselect-1.4.17.ebuild
new file mode 100644
index 000000000000..0ed9a1b499a1
--- /dev/null
+++ b/app-admin/eselect/eselect-1.4.17.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
+
+LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc emacs vim-syntax"
+
+DEPEND="sys-apps/sed
+ || (
+ sys-apps/coreutils
+ app-misc/realpath
+ )"
+RDEPEND="${DEPEND}
+ sys-apps/file
+ sys-libs/ncurses:0"
+BDEPEND="doc? ( dev-python/docutils )"
+PDEPEND="emacs? ( app-emacs/eselect-mode )
+ vim-syntax? ( app-vim/eselect-syntax )"
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newbashcomp misc/${PN}.bashcomp ${PN}
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
+ if use doc; then
+ docinto html
+ dodoc *.html doc/*.html doc/*.css
+ fi
+
+ # needed by news module
+ keepdir /var/lib/gentoo/news
+ if ! use prefix; then
+ fowners root:portage /var/lib/gentoo/news
+ fperms g+w /var/lib/gentoo/news
+ fi
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for the portage group:
+ # merging changes the group back to root
+ if ! use prefix; then
+ chgrp portage "${EROOT}/var/lib/gentoo/news" \
+ && chmod g+w "${EROOT}/var/lib/gentoo/news"
+ fi
+}