summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-10-08 17:15:44 -0700
committerMatt Turner <mattst88@gentoo.org>2019-10-08 17:18:42 -0700
commit5e9f2ae2f5f271ee5a8b46880a1b6e1d1130a92d (patch)
tree261ef232c572d3392cf707a9ba4ee969d8b2de90 /app-admin/stow
parentapp-admin/stow-2.2.2-r1: amd64 stable, bug 697022 (diff)
downloadgentoo-5e9f2ae2f5f271ee5a8b46880a1b6e1d1130a92d.tar.gz
gentoo-5e9f2ae2f5f271ee5a8b46880a1b6e1d1130a92d.tar.bz2
gentoo-5e9f2ae2f5f271ee5a8b46880a1b6e1d1130a92d.zip
app-admin/stow: Version bump to 2.3.1
Closes: https://bugs.gentoo.org/692996 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-admin/stow')
-rw-r--r--app-admin/stow/Manifest1
-rw-r--r--app-admin/stow/stow-2.3.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/stow/Manifest b/app-admin/stow/Manifest
index 55d3c753e6eb..272515f53bc2 100644
--- a/app-admin/stow/Manifest
+++ b/app-admin/stow/Manifest
@@ -1 +1,2 @@
DIST stow-2.2.2.tar.gz 579324 BLAKE2B fc4ab7f386e8245b361cee5fc0decd91caec543ec6178c82720866c33a974ba9d68e999a68c3b7357d873ab1b58bb8b022bf02dad029972f42c317ffc288bd04 SHA512 8a3e5da6b5cb4c1ee1b512bae5a9859f83659d5de05f7a9af1dd09df2a32f6b8c6d43b79736db91232c43621d542041d4ef92eb088925796adad0676f200a9b5
+DIST stow-2.3.1.tar.gz 654191 BLAKE2B 9fd54fd3ff76aa7b72ed973cd6d70b8dc747fa3bb1ecc6bedd221b308d7d141a21a2f077c67efb432f2c7c4fb6bd126639038b196946206bf4a7f95040477ab2 SHA512 e9a7de1a6f10eaf7cdbe6737e0a8be1498e2eac46b6c57e65b83759b061efd1c0db45f7cba123e35428307e3aebe5baef9ea8bd4b5eb6ec5e1b159117a760441
diff --git a/app-admin/stow/stow-2.3.1.ebuild b/app-admin/stow/stow-2.3.1.ebuild
new file mode 100644
index 000000000000..834867c86051
--- /dev/null
+++ b/app-admin/stow/stow-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-functions
+
+DESCRIPTION="GNU Stow is a symlink farm manager"
+HOMEPAGE="https://www.gnu.org/software/stow/"
+SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+
+DEPEND="dev-lang/perl
+ test? (
+ dev-perl/IO-stringy
+ virtual/perl-Test-Harness
+ dev-perl/Test-Output
+ )"
+RDEPEND="dev-lang/perl:="
+
+src_configure() {
+ perl_set_version
+ econf "--with-pmdir=${VENDOR_LIB}"
+}