summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-19 12:54:38 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-19 12:59:32 +0200
commit47fb08c06fa91a5917fe3a7d23246f819546d1cf (patch)
treee3b2b0ca74519e4a656d6209306c303889c6838c /app-cdr/xbiso
parentdev-util/debugedit: Depend on fixed elfutils version (diff)
downloadgentoo-47fb08c06fa91a5917fe3a7d23246f819546d1cf.tar.gz
gentoo-47fb08c06fa91a5917fe3a7d23246f819546d1cf.tar.bz2
gentoo-47fb08c06fa91a5917fe3a7d23246f819546d1cf.zip
app-cdr/xbiso: Bump to EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-cdr/xbiso')
-rw-r--r--app-cdr/xbiso/files/xbiso-0.6.1-libs.patch4
-rw-r--r--app-cdr/xbiso/xbiso-0.6.1-r3.ebuild38
2 files changed, 40 insertions, 2 deletions
diff --git a/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch b/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
index 5b48ba674230..32b3523d9c92 100644
--- a/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
+++ b/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
@@ -1,5 +1,5 @@
---- configure.in.orig 2014-12-02 18:56:23.000000000 +0300
-+++ configure.in 2014-12-02 19:09:46.724190436 +0300
+--- a/configure.in 2014-12-02 18:56:23.000000000 +0300
++++ b/configure.in 2014-12-02 19:09:46.724190436 +0300
@@ -6,13 +6,13 @@
dnl Checks for libraries.
diff --git a/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild b/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild
new file mode 100644
index 000000000000..421a28f52baf
--- /dev/null
+++ b/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="Xbox xdvdfs ISO extraction utility"
+HOMEPAGE="https://sourceforge.net/projects/xbiso/"
+SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ftp"
+
+RDEPEND="ftp? ( <net-libs/ftplib-4 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+ sed -i -e 's:C) $(CFLAGS):C) $(LDFLAGS) $(CFLAGS):' Makefile.in || die #337769
+ eapply "${FILESDIR}/${P}-libs.patch"
+ mv configure.in configure.ac || die #426262
+ eautoreconf
+}
+
+src_configure() {
+ # for this package, interix behaves the same as BSD
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_BSD
+
+ econf \
+ $(use_enable ftp)
+}
+
+src_install() {
+ dobin xbiso
+ dodoc CHANGELOG README
+}