summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-01 16:26:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-01 16:35:07 -0500
commitee6ff1abdb03f580aedfe98c6259cc3568c4ec2a (patch)
treeece7e00bace57c4079893162577e565d169b1ef1 /app-crypt/certbot
parentQA: Revert "net-analyzer/wireshark: Version 3.3.1" (diff)
downloadgentoo-ee6ff1abdb03f580aedfe98c6259cc3568c4ec2a.tar.gz
gentoo-ee6ff1abdb03f580aedfe98c6259cc3568c4ec2a.tar.bz2
gentoo-ee6ff1abdb03f580aedfe98c6259cc3568c4ec2a.zip
app-crypt/certbot: switch to eclass for distutils depend
Closes: https://bugs.gentoo.org/745846 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/certbot-1.7.0.ebuild4
-rw-r--r--app-crypt/certbot/certbot-1.8.0.ebuild4
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild4
3 files changed, 3 insertions, 9 deletions
diff --git a/app-crypt/certbot/certbot-1.7.0.ebuild b/app-crypt/certbot/certbot-1.7.0.ebuild
index 7a862586d0d5..6f5c706cae23 100644
--- a/app-crypt/certbot/certbot-1.7.0.ebuild
+++ b/app-crypt/certbot/certbot-1.7.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -23,9 +24,7 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
>=app-crypt/acme-1.6.0[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
@@ -37,7 +36,6 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
distutils_enable_tests pytest
diff --git a/app-crypt/certbot/certbot-1.8.0.ebuild b/app-crypt/certbot/certbot-1.8.0.ebuild
index f5147fca7936..8496941da96c 100644
--- a/app-crypt/certbot/certbot-1.8.0.ebuild
+++ b/app-crypt/certbot/certbot-1.8.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -23,9 +24,7 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
>=app-crypt/acme-1.6.0[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
@@ -37,7 +36,6 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
distutils_enable_tests pytest
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index f5147fca7936..8496941da96c 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=(python{3_6,3_7,3_8})
+DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -23,9 +24,7 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
- ${CDEPEND}
>=app-crypt/acme-1.6.0[${PYTHON_USEDEP}]
>=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
@@ -37,7 +36,6 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
distutils_enable_tests pytest